Bug 1415615 - conditional flag for pool id is required in cockpit-ovirt gdeploy plugin.
Summary: conditional flag for pool id is required in cockpit-ovirt gdeploy plugin.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.1.1
: 0.10.7-0.0.13
Assignee: Ramesh N
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2017-01-23 09:13 UTC by RamaKasturi
Modified: 2017-04-21 09:35 UTC (History)
5 users (show)

Fixed In Version: cockpit-ovirt-0.10.7-0.0.13
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:35:55 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
rnachimu: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 72642 master MERGED gdeploy: add pool-ID and repos conditionally to CDN 2017-02-21 16:30:43 UTC
oVirt gerrit 72796 ovirt-4.1 MERGED gdeploy: add pool-ID and repos conditionally to CDN 2017-02-21 16:30:56 UTC

Description RamaKasturi 2017-01-23 09:13:08 UTC
Description of problem:
RHV-H does not require any pool id for subscribing to repos. It is only RHEL which requires the pool id. Conditional flag for pool id should be provided as if user does not provide a pool id for RHV-H node while deploying gluster below error is thrown.

https://paste.fedoraproject.org/530799/14848340/

Version-Release number of selected component (if applicable):
cockpit-ovirt-dashboard-0.10.7-0.0.3.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install latest RHV-H node.
2. Login to cockpit UI and select 'Enable gluster Dashboard'
3. Now provide all the inputs except pool id as this is not required on RHV-H node.

Actual results:
Below error is thrown while deploying gluster on RHV-H nodes.

TASK [Attach to Red Hat subscription pool] *************************************
fatal: [10.70.36.80]: FAILED! => {"changed": true, "cmd": ["subscription-manager", "attach", "--pool="], "delta": "0:00:12.017952", "end": "2017-01-19 07:53:29.406280", "failed": true, "rc": 1, "start": "2017-01-19 07:53:17.388328", "stderr": "", "stdout": "Pool with id  could not be found.", "stdout_lines": ["Pool with id  could not be found."], "warnings": []}
        to retry, use: --limit @/tmp/tmpLXw_5X/subscription_manager.retry
 
PLAY RECAP *********************************************************************
10.70.36.80                : ok=1    changed=1    unreachable=0    failed=1  
 

Expected results:
conditional flag for pool id should be present 

Additional info:

Comment 1 RamaKasturi 2017-01-23 09:17:43 UTC
same is required for packages a all the rpms are pre-pacakged on RHV-H node and user does not need to install any package.

Comment 2 Sahina Bose 2017-01-23 09:42:32 UTC
(In reply to RamaKasturi from comment #1)
> same is required for packages a all the rpms are pre-pacakged on RHV-H node
> and user does not need to install any package.

In this case can the registration step be skipped?

Comment 3 SATHEESARAN 2017-01-23 17:12:53 UTC
(In reply to Sahina Bose from comment #2)
> (In reply to RamaKasturi from comment #1)
> > same is required for packages a all the rpms are pre-pacakged on RHV-H node
> > and user does not need to install any package.
> 
> In this case can the registration step be skipped?

Sahina,

But this should not hinder the user who prefers RHEL 7 Server platform over RHV-H

Comment 4 RamaKasturi 2017-01-25 06:38:11 UTC
(In reply to Sahina Bose from comment #2)
> (In reply to RamaKasturi from comment #1)
> > same is required for packages a all the rpms are pre-pacakged on RHV-H node
> > and user does not need to install any package.
> 
> In this case can the registration step be skipped?

sahina, yes, it can be skipped. But i think we need to document this well so that user is clear on what steps to follow with RHV-H and RHEL.

Comment 5 Ramesh N 2017-02-19 18:22:14 UTC
conditionals for package is already taken care in bz#1422935. So changing the description accordingly.

Comment 6 RamaKasturi 2017-03-09 11:30:21 UTC
Ramesh, from comment 5 i see that bug fix for this is leaving the packages text blank and update hosts unchecked. Is that right?

If yes, i can mark this verified as the other bug in comment 5 is already verified.

Comment 7 Ramesh N 2017-03-09 12:02:22 UTC
(In reply to RamaKasturi from comment #6)
> Ramesh, from comment 5 i see that bug fix for this is leaving the packages
> text blank and update hosts unchecked. Is that right?
> 

This is changed as part of the bz#1422935. So its right.

> If yes, i can mark this verified as the other bug in comment 5 is already
> verified.

Comment 8 RamaKasturi 2017-03-09 17:44:46 UTC
As per comment 7 since the bug fix for this is part of bz#1422935 which is verified, marking this bug verified as well.


Note You need to log in before you can comment on or make changes to this bug.