Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415623 - [RFE] posiblity to change temp folder of engine-backup
Summary: [RFE] posiblity to change temp folder of engine-backup
Keywords:
Status: CLOSED DUPLICATE of bug 1439332
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Yedidyah Bar David
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 09:34 UTC by Jaroslav Spanko
Modified: 2020-02-14 18:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-13 07:30:42 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1439332 0 medium CLOSED [backup] Engine backup stages to /tmp, can fill disk to 100% and down rhv-m 2021-02-22 00:41:40 UTC

Internal Links: 1439332

Description Jaroslav Spanko 2017-01-23 09:34:01 UTC
For now it is not possible to change temp folder of engine backup - /tmp to something else.

2017-01-18 03:05:02 27138: Start of engine-backup mode backup scope all file /var/ovirt/backup.tar
2017-01-18 03:05:02 27138: Backing up:
2017-01-18 03:05:02 27138: Generating pgpass
2017-01-18 03:05:02 27138: Creating temp folder /tmp/engine-backup.oLpdkwhWhp/tar
2017-01-18 03:05:02 27138: - Files
2017-01-18 03:05:03 27138: Backing up files to /tmp/engine-backup.oLpdkwhWhp/tar/files
2017-01-18 03:05:07 27138: - Engine database 'engine'
2017-01-18 03:05:07 27138: Backing up database to /tmp/engine-backup.oLpdkwhWhp/tar/db/engine_backup.db
2017-01-18 03:05:21 27138: - DWH database 'ovirt_engine_history'
2017-01-18 03:05:21 27138: Backing up dwh database to /tmp/engine-backup.oLpdkwhWhp/tar/db/dwh_backup.db

Actually engine-backup use mktemp to create tmp folder.
Workaround is to change /usr/share/ovirt-engine/bin/engine-backup.sh and set/change TEMP_FOLDER line.

Could  be possible to define different temp directory in engine-backup option.

Thank you

Comment 3 Sandro Bonazzola 2017-04-10 07:12:45 UTC
Changing temp dir is already possible. engine-backup honor system temporary folder defined in $TMPDIR.
If a different tmpdir is needed, a TMPDIR=/path/to/tmpdir engine-backup <args> should be enough.

Is something different desired / expected here?

Comment 4 Sandro Bonazzola 2017-04-13 07:30:42 UTC

*** This bug has been marked as a duplicate of bug 1439332 ***


Note You need to log in before you can comment on or make changes to this bug.