Bug 141564 - URLs open in new windows instead of tabs
URLs open in new windows instead of tabs
Status: CLOSED DUPLICATE of bug 138789
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 22:24 EST by Anand Buddhdev
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Buddhdev 2004-12-01 22:24:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
In the advanced section of preferences, there is an option to 'open
links from other applications in a new tab in the most recent window'.
Even though I have enabled this option, URLs still open in new windows.

Version-Release number of selected component (if applicable):
1.0-2.fc3

How reproducible:
Always

Steps to Reproduce:
1. In the advanced section of the preferences dialog, choose the
option to open URLs in a new tab of the most recent window
2. Start firefox
3. Start another application like evolution or thunderbird, and click
on a link in it
    

Actual Results:  The link opens in a new firefox window

Expected Results:  The link is supposed to open in a new tab of the
original firefox window

Additional info:

It seems that most applications will simply run 'firefox URL'. this
will invoke /usr/bin/firefox. When I examine this script, the last but
one line is:

exec $MOZ_CLIENT_PROGRAM $MOZ_CLIENT_PROGRAM_PARAM
"openurl($opt,new-window)" 2>/dev/null >/dev/null

So it seems that despite the preference setting, a new window will
always open. I edited /usr/bin/firefox and changed the word 'window'
to 'tab', and now all URLs open in a new tab. But this is an annoying
bug that has been around since before version 1.0 of firefox, and
needs a proper fix.
Comment 1 Rich Renomeron 2004-12-01 22:46:21 EST
I tried removing the word "window", and it seems that doing that will
make the script honor whatever the user preference is (new tab, new
window, current tab).
Comment 2 Anand Buddhdev 2004-12-01 22:55:39 EST
Rich,

You are absolutely correct. I tried it as you suggested. I removed the
'new-tab' part, and now firefox follows the setting in the
preferences. So this seems to be the correct fix. Now we wait and see
if Warren manages to get it into the next update.
Comment 3 Warren Togami 2004-12-02 01:02:12 EST

*** This bug has been marked as a duplicate of 138789 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:07:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.