Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415640 - [ubuntu]: ceph-base package missing from the 'Tools' repo on the latest ubuntu build
Summary: [ubuntu]: ceph-base package missing from the 'Tools' repo on the latest ubunt...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Build
Version: 2.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.2
Assignee: Ken Dreyer (Red Hat)
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 10:29 UTC by Tejas
Modified: 2017-03-14 15:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-14 15:48:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0514 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.2 bug fix and enhancement update 2017-03-21 07:24:26 UTC

Description Tejas 2017-01-23 10:29:13 UTC
Description of problem:
        I am trying to install ceph-mds on the latest Ubuntu build. The ceph-base package is not present in the Tools repo.


Version-Release number of selected component (if applicable):
http://download-node-02.eng.bos.redhat.com/rcm-guest/ceph-drops/2/Ceph-2-Ubuntu-x86_64-20170120.t.0/

How reproducible:
Always



Additional info:

The Tools repo does not have ceph-base package . It is essential for ceph-mds installation.

The same package is present in the RHEl repos.

# ll
total 614650
-r--r--r--. 1 root root 13572270 Jan 20 23:17 ceph-common_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root 14197790 Jan 20 23:19 ceph-common_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  1045390 Jan 20 23:18 ceph-fs-common_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  1044316 Jan 20 23:19 ceph-fs-common_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  2757268 Jan 20 23:18 ceph-fuse_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  2802768 Jan 20 23:19 ceph-fuse_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  3629266 Jan 20 23:18 ceph-mds_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  3710970 Jan 20 23:19 ceph-mds_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  1027210 Jan 20 23:17 ceph-resource-agents_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  1027052 Jan 20 23:19 ceph-resource-agents_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root 50824566 Jan 20 23:17 ceph-test_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root 49864950 Jan 20 23:19 ceph-test_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  2776356 Jan 20 23:18 libcephfs1_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  2826148 Jan 20 23:19 libcephfs1_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root 42921690 Jan 20 23:18 libcephfs-dev_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root 40163528 Jan 20 23:19 libcephfs-dev_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  2680710 Jan 20 23:18 librados2_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  2720810 Jan 20 23:19 librados2_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root 44032528 Jan 20 23:18 librados-dev_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root 42033886 Jan 20 23:19 librados-dev_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  3178766 Jan 20 23:18 librbd1_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  3227074 Jan 20 23:19 librbd1_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root 81515300 Jan 20 23:17 librbd-dev_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root 67337130 Jan 20 23:19 librbd-dev_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  3732114 Jan 20 23:17 librgw2_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  3891724 Jan 20 23:19 librgw2_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root 63304552 Jan 20 23:18 librgw-dev_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root 59637362 Jan 20 23:19 librgw-dev_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  1024408 Jan 20 23:17 python-ceph_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  1024356 Jan 20 23:19 python-ceph_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  1238944 Jan 20 23:18 python-cephfs_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  1247570 Jan 20 23:19 python-cephfs_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  1587924 Jan 20 23:18 python-rados_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  1659446 Jan 20 23:19 python-rados_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  1297632 Jan 20 23:17 python-rbd_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  1327754 Jan 20 23:19 python-rbd_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  1260126 Jan 20 23:18 radosgw_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  1279944 Jan 20 23:19 radosgw_10.2.5-3redhat1xenial_amd64.deb
-r--r--r--. 1 root root  2470112 Jan 20 23:18 rbd-mirror_10.2.5-3redhat1trusty_amd64.deb
-r--r--r--. 1 root root  2489744 Jan 20 23:19 rbd-mirror_10.2.5-3redhat1xenial_amd64.deb
[root@magna006 ceph]#

Comment 6 Tejas 2017-01-25 14:01:42 UTC
Package is present in the latest repos. Moving to Verified state.

Comment 8 errata-xmlrpc 2017-03-14 15:48:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html


Note You need to log in before you can comment on or make changes to this bug.