Bug 1415681 - [Patch] disable subscription-manager also after client config rpm is installed
Summary: [Patch] disable subscription-manager also after client config rpm is installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: 3.0.4
: 3.0.x
Assignee: Martin Minar
QA Contact: Vratislav Hutsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 12:23 UTC by Satoru SATOH
Modified: 2018-07-10 16:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-10 16:00:36 UTC


Attachments (Terms of Use)
An experimental patch to disable subscription-manager after rhui client config rpm is installed (792 bytes, patch)
2017-01-23 12:23 UTC, Satoru SATOH
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2153 None None None 2018-07-10 16:00:57 UTC

Description Satoru SATOH 2017-01-23 12:23:31 UTC
Created attachment 1243575 [details]
An experimental patch to disable subscription-manager after rhui client config rpm is installed

Description of problem:
Currently, RHN classic yum plugin is disabled after installation of
RHUI client config rpm but subscription-manager is not although it
also needs to be disabled. So every time users run yum, an warning
is out to encourage users to register the client host with subscription-manager.
 
Version-Release number of selected component (if applicable): RHUI 3.0 Beta.2

How reproducible: Always

Steps to Reproduce:
1. Install RHUI client config to any clients subscription-manager is installed and untouched (that is, its yum plugin is enabled).
2. Run yum

Actual results:
Because subscription-manager yum plugin is enabled by default and
RHUI clients never register to RHSM server (portal/satellite),
an warning "This system is not registered to Red Hat Subscription
Management ..." was out during yum operation such as 'yum repolist',
'yum install ...'.


Expected results: No subscription-manager related warnings during running yum.


Additional info: I made an experimental patch for the client config rpm template.

Comment 11 errata-xmlrpc 2018-07-10 16:00:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2153


Note You need to log in before you can comment on or make changes to this bug.