Bug 141569 - still a need to load oss compat modules
still a need to load oss compat modules
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 00:04 EST by Richard Henderson
Modified: 2014-03-16 22:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 21:37:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Henderson 2004-12-02 00:04:21 EST
There are a number of legacy binary-only widgets, most notably
the macromedia flash plugin, that don't understand ALSA.  It
would probably be most helpful for many of our users if the OSS
compatibility modules were always loaded, assuming *some* sound
driver is active.  Failing that, some sort of /etc/sysconfig
switch would be nice.

It could be that something else odd is going on here, since a
clean install on a machine with snd_emu10k1 does automatically
load snd_pcm_oss, whereas an upgrade from FC2 on a machine with
snd_intel8x0 does not.
Comment 1 Bill Nottingham 2004-12-02 00:11:56 EST
What's your /etc/modprobe.conf and /etc/modprobe.conf.dist look like
in those cases - any differences aside from just the module name?

Notably, the:

install snd-pcm /sbin/modprobe --ignore-install snd-pcm &&
/sbin/modprobe snd-pcm-oss
install snd-pcm-device /sbin/modprobe --ignore_install snd-seq-device
&& /sbin/modprobe snd-seq-oss

lines in /etc/modprobe.conf.dist should cause the oss modules to get
loaded. (snd-mixer-oss gets pulled in by snd-pcm-oss.)
Comment 2 Richard Henderson 2004-12-02 00:50:30 EST
That must be it -- on the system upgraded from FC2, there is 
no /etc/modprobe.conf.dist file (and the /etc/modprobe.conf
file contains very little of interest), whereas the system
with FC3 installed fresh has it.
Comment 3 Richard Henderson 2004-12-02 01:02:55 EST
Confirmed.  Copying over /etc/modprobe.conf.dist means that an
explicit modprobe is no longer needed.

I'd have to start from FC2 scratch in order to determine if this
is a bug in the upgrade widgets, or whether this is pilot error
purging all of the /etc configuration .rpmsave/.rpmnew files after
the upgrade to FC3.  I don't *recall* removing the file in question,
but I can't prove it.
Comment 4 Bill Nottingham 2004-12-03 21:37:32 EST
Closing as 'WORKSFORME'; please reopen if you can get a good
reproducer. (I haven't seen other reports of the file/files being
missing on upgrade in bugzilla.)

Note You need to log in before you can comment on or make changes to this bug.