Bug 1415694 - /usr/sbin is sometimes used in RPM macros instead of %{_sbindir}
Summary: /usr/sbin is sometimes used in RPM macros instead of %{_sbindir}
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.4
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 13:07 UTC by Milos Malik
Modified: 2018-04-10 12:26 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-174.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 12:26:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0763 0 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2018-04-10 12:08:10 UTC

Description Milos Malik 2017-01-23 13:07:07 UTC
Description of problem:
* maybe a cosmetic problem

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-110.el7.noarch

How reproducible:
always

Steps to Reproduce:
# grep selinuxenabled /usr/lib/rpm/macros.d/macros.selinux-policy 
if %{_sbindir}/selinuxenabled && [ "${SELINUXTYPE}" = "${_policytype}" ]; then \
  if %{_sbindir}/selinuxenabled && [ "${SELINUXTYPE}" = "${_policytype}" ]; then \
if %{_sbindir}/selinuxenabled && [ "${SELINUXTYPE}" = "${_policytype}" ]; then \
if /usr/sbin/selinuxenabled && [ "${SELINUXTYPE}" = "${_policytype}" ]; then \
#

Actual results:
* when calling selinuxenabled %{_sbindir} is used 3 times, once full path is used

Expected results:
* when calling selinuxenabled %{_sbindir} is used 4 times

Comment 6 errata-xmlrpc 2018-04-10 12:26:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0763


Note You need to log in before you can comment on or make changes to this bug.