Bug 1415705 - Repository virtio-win-stable is listed more than once in the configuration
Summary: Repository virtio-win-stable is listed more than once in the configuration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-release
Classification: oVirt
Component: General
Version: 4.0.1
Hardware: Unspecified
OS: Linux
low
low
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Sandro Bonazzola
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 13:27 UTC by Evgheni Dereveanchin
Modified: 2019-04-28 13:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-20 11:02:20 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
jbelka: testing_plan_complete-
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71229 0 master MERGED repos: versioned virtio-win-stable 2017-01-26 09:46:29 UTC

Description Evgheni Dereveanchin 2017-01-23 13:27:22 UTC
Description of problem:
When upgrading from 3.6 to 4.0, both release files contain definitions for the same repo name. It is expected that users remove the older release RPM, however due to bz#1415700 repo files are left over causing yum warning causing automation issues since yum returns a non-zero exit code due to duplicate repos.

Version-Release number of selected component (if applicable):
ovirt-release40-4.0.6.1-1.noarch

How reproducible:
always

Steps to Reproduce:
1. install 3.6 and 4.0 release RPMs on a CentOS 7 machine:
 # yum install http://resources.ovirt.org/pub/yum-repo/ovirt-release36.rpm
 # yum install http://resources.ovirt.org/pub/yum-repo/ovirt-release40.rpm

2. remove 3.6 RPM (this imitates a successful update to 4.0)
 # yum remove ovirt-release36

3. check for updates 
# yum check-update

Actual results:

 ...
 Failed to set locale, defaulting to C
 Loaded plugins: fastestmirror
 Repository virtio-win-stable is listed more than once in the configuration
 ...

 # echo $?
 100

Expected results:

No warning displayed and yum returns exit code 0
 # echo $?
 100

Additional info:
this seems to be caused by virtio-win-stable defined in two *dependencies repo files:

# grep -r virtio-win-stable /etc/yum.repos.d/
/etc/yum.repos.d/ovirt-4.0-dependencies.repo:[virtio-win-stable]
/etc/yum.repos.d/ovirt-3.6-dependencies.repo:[virtio-win-stable]

A workaround to bz#1415700 would be to remove 3.6 repo files manually. A proper fix is to give unique names to virtio-win-stable in each release or supply this dependency in a separate RPM so that it can be shared by several release files.

Comment 1 Jiri Belka 2017-10-04 12:14:49 UTC
ok, based on steps on #0

# yum repolist -v | egrep '^Repo-(id|baseurl).*virtio'
Repo-id      : ovirt-master-virtio-win-latest
Repo-baseurl : http://fedorapeople.org/groups/virt/virtio-win/repo/latest/
Repo-id      : virtio-win-stable
Repo-baseurl : http://fedorapeople.org/groups/virt/virtio-win/repo/stable/

Comment 2 Sandro Bonazzola 2017-12-20 11:02:20 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.