Bug 1415708 - upgrade to latest rhsm version sets the fact "virt.is_guest" to unknown
Summary: upgrade to latest rhsm version sets the fact "virt.is_guest" to unknown
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Alex Wood
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 13:40 UTC by Shwetha Kallesh
Modified: 2017-08-01 19:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:20:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin/subscription-manager/commit/908316a9f2ecbc03bf182c71f0b2e07bb4724c23 None None None 2019-11-26 06:00:27 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Shwetha Kallesh 2017-01-23 13:40:40 UTC
Description of problem:

upgrade to latest rhsm version sets the fact "virt.is_guest" to unknown 

Version-Release number of selected component (if applicable):
[root@bkr-hv02-guest17 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.19.1-1.git.0.9d9da76.el6
python-rhsm: 1.19.0-1.git.2.cb8193d.el6

How reproducible:


Steps to Reproduce:
[root@bkr-hv02-guest17 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.18.6-1.git.8.af7baf2.el6
python-rhsm: 1.18.6-1.git.0.9de351c.el6

[root@bkr-hv02-guest17 ~]# subscription-manager facts --list | grep "virt.is_guest"virt.is_guest: True

[root@bkr-hv02-guest17 ~]# rpm -Uvh subscription-manager* python-rhsm*
Preparing...                ########################################### [100%]
   1:python-rhsm-certificate########################################### [ 14%]
   2:python-rhsm            ########################################### [ 29%]
   3:subscription-manager   ########################################### [ 43%]
   4:subscription-manager-gu########################################### [ 57%]
   5:subscription-manager-fi########################################### [ 71%]
   6:subscription-manager-mi########################################### [ 86%]
   7:subscription-manager-pl########################################### [100%]

[root@bkr-hv02-guest17 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.19.1-1.git.0.9d9da76.el6
python-rhsm: 1.19.0-1.git.2.cb8193d.el6

[root@bkr-hv02-guest17 ~]# subscription-manager facts --list | grep "virt.is_guest"
virt.is_guest: Unknown

Actual results:

[root@bkr-hv02-guest17 ~]# subscription-manager facts --list | grep "virt.is_guest"
virt.is_guest: Unknown

Expected results:
Fact should remain unchanged
[root@bkr-hv02-guest17 ~]# subscription-manager facts --list | grep "virt.is_guest"
virt.is_guest: True

Additional info:

Comment 3 Alex Wood 2017-01-31 16:10:35 UTC
What architecture and virtualization type was the machine you ran this test on?

To find the architecture: python -c 'import platform; print(platform.machine())'
To find the virtualization type: virt-what

Comment 5 Shwetha Kallesh 2017-02-01 14:40:08 UTC
[root@bkr-hv03-guest05 ~]# python -c 'import platform; print(platform.machine())'
x86_64
[root@bkr-hv03-guest05 ~]# virt-what
kvm


I lost that beaker machine , but I can still reproduce on a newly reserved machine

Before Updating: 

[root@bkr-hv03-guest05 ~]# subscription-manager  version
server type: This system is currently not registered.
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.18.8-1.el6
python-rhsm: 1.18.6-1.el6

[root@bkr-hv03-guest05 ~]# subscription-manager facts --list | grep "guest"
network.fqdn: bkr-hv03-guest05.dsal.lab.eng.bos.redhat.com
network.hostname: bkr-hv03-guest05.dsal.lab.eng.bos.redhat.com
uname.nodename: bkr-hv03-guest05.dsal.lab.eng.bos.redhat.com
virt.is_guest: True

After Updating:

[root@bkr-hv03-guest05 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.19.1-1.git.0.9d9da76.el6
python-rhsm: 1.19.0-1.git.2.cb8193d.el6


[root@bkr-hv03-guest05 ~]# subscription-manager facts --list | grep "guest"
network.hostname: bkr-hv03-guest05.dsal.lab.eng.bos.redhat.com
uname.nodename: bkr-hv03-guest05.dsal.lab.eng.bos.redhat.com
virt.is_guest: Unknown

Comment 6 John Sefler 2017-02-01 15:22:15 UTC
This is a valid bug, but it does not apply to RHEL6.9 where subscription-manager-1.18 is targeted for release.

I am moving this bug to RHEL7.4 which is where subscription-manager-1.19 will land.

Comment 10 Alex Wood 2017-03-17 15:41:33 UTC
commit 908316a9f2ecbc03bf182c71f0b2e07bb4724c23
Author: Alex Wood <awood@redhat.com>
Date:   Thu Feb 2 14:29:10 2017 -0500

    1415708: Fix issues with facts gathering.
    
    * Add missing virt uuid to facts.
    * Remove duplicate hwprobe and facts code
    * Fix hwprobe unit tests

Comment 12 Shwetha Kallesh 2017-04-11 07:54:16 UTC
[root@dhcp35-160 ~]# subscription-manager facts --list | grep "virt.is_guest"
virt.is_guest: false

[root@dhcp35-160 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7


Fact is no longer modified by updating the rhsm packages , so moving bug to verified

[root@dhcp35-160 ~]# subscription-manager facts --list | grep "virt.is_guest"
virt.is_guest: false

[root@dhcp35-160 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.5-1.el7
python-rhsm: 1.19.4-1.el7

Comment 13 errata-xmlrpc 2017-08-01 19:20:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.