Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415727 - Touchpad not wowrking on lenovo yoga 700 11.6"
Summary: Touchpad not wowrking on lenovo yoga 700 11.6"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 14:44 UTC by Wade Berrier
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-28 17:42:18 UTC
Type: Bug


Attachments (Terms of Use)
dmesg output (65.54 KB, text/plain)
2017-01-23 14:44 UTC, Wade Berrier
no flags Details
lsusb output (48.64 KB, text/plain)
2017-01-23 14:45 UTC, Wade Berrier
no flags Details
lspci output (6.41 KB, text/plain)
2017-01-23 14:47 UTC, Wade Berrier
no flags Details
acpidump ascii output (611.68 KB, text/plain)
2017-01-25 15:58 UTC, Wade Berrier
no flags Details

Description Wade Berrier 2017-01-23 14:44:10 UTC
Created attachment 1243612 [details]
dmesg output

Description of problem:

The touchpad doesn't work.

I've seen some reports online that this touchpad may be connected via i2c instead of usb.

I'm running kernel 4.9.4-201.fc25.x86_64

NOTE, the touchscreen does work.

Also note, to get the kernel booting at all, I had to pass "acpi=noirq" to the kernel command line.

I'm attaching lsusb/lspci/dmesg output.

Any other information I can provide that would be useful?

Comment 1 Wade Berrier 2017-01-23 14:45:00 UTC
Created attachment 1243613 [details]
lsusb output

Comment 2 Wade Berrier 2017-01-23 14:47:40 UTC
Created attachment 1243614 [details]
lspci output

Comment 3 Benjamin Tissoires 2017-01-25 10:08:01 UTC
Can you attach the output of acpidump (as root) also. I want to check if the device is enumerated in the DSDT.

Comment 4 Wade Berrier 2017-01-25 15:58:28 UTC
Created attachment 1244295 [details]
acpidump ascii output

Here's the dump.  Thanks for taking a look at this.

Comment 5 Benjamin Tissoires 2017-01-26 08:18:41 UTC
Thanks for the logs. So it appears the touchpad is connected with HID over I2C, but the device is not enumerated. The problem is that the I2C adapater is on the PCI0 bus, meaning that the adapter just failed at loading. The lspci output shows that you are using intel_lpss_pci for those adapter, and the dmesg shows that they are failing at probing:

[    4.195021] intel-lpss 0000:00:15.0: enabling device (0000 -> 0002)
[    4.195031] intel-lpss 0000:00:15.0: can't find IRQ for PCI INT A; please try using pci=biosirq
[    4.195065] intel-lpss: probe of 0000:00:15.0 failed with error -22
[    4.207148] intel-lpss 0000:00:15.1: enabling device (0000 -> 0002)
[    4.207159] intel-lpss 0000:00:15.1: can't find IRQ for PCI INT B; please try using pci=biosirq
[    4.207182] intel-lpss: probe of 0000:00:15.1 failed with error -22

So please try booting with pci=biosirq as mentioned, and if it still doesn't help, we might be missing a better IRQ support for Skylake here. In that case, could you try the v4.10-rc from the Fedora Rawhide nodebug kernel[1]?

[1] https://fedoraproject.org/wiki/RawhideKernelNodebug

Comment 6 Wade Berrier 2017-01-28 17:42:18 UTC
Short story: user error, removing "acpi=noirq" from the boot parameters resulted in a functional touchpad

Long story: I was having trouble booting the installer from a usb thumbstick, through trial and error I attempted adding "acpi=noirq" and booting from a usb dvd drive.

It think it was the booting from a dvd drive that fixed booting, and not the acpi=noirq (that's my best guess).

So, removing "acpi=noirq" resolves the issue.

My apologies for the false alarm.

Comment 7 Benjamin Tissoires 2017-01-30 12:46:52 UTC
No worries. Glad you found out the issue.


Note You need to log in before you can comment on or make changes to this bug.