Bug 1415730 - rhcert-ci freeze if we try to reuse a sandbox_id
Summary: rhcert-ci freeze if we try to reuse a sandbox_id
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Certification Program
Classification: Red Hat
Component: Certification Workflow Engine
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Kun Yan
QA Contact: Suprith Gangawar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 14:58 UTC by Gonéri Le Bouder
Modified: 2017-02-20 14:36 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-03 00:49:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gonéri Le Bouder 2017-01-23 14:58:40 UTC
Description of problem:

We cannot reuse an existing sandbox ID.

[stack@director ~]$ sudo rhcert-ci run --key-file /home/stack/key.file --debug high

Error: could not get vendor product info from the catalog:
You have not use xmlrpc call to login user bkopilov
Catalog: https://hardware.redhat.com/xmlrpc.cgi
(Fault code: -32000)
Continue? (yes|no)

Version-Release number of selected component (if applicable):



Steps to Reproduce:
1. Connect to the interface
2. Generate a sandbox_id
3. Redeploy the environment
4. Try to reuse the sandbox_id

Actual results:

- The rhcert-ci CLI tool freeze
- We cannot do a non interactive run of rhcert-ci

Additional info:

I put the severity to urgent because this break the Distributed-CI integration.

Comment 1 Greg Nichols 2017-01-23 15:15:31 UTC
Peng, could you take a look at this?  Perhaps there is some permissions issue with the account?

Comment 2 Anshul Behl 2017-01-23 16:25:16 UTC
Please try the new build at 

https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=534569

This should fix the issue with a new parameter added in test_config.json named undercloud_stackrc which can be configured before running rhcert-ci

Comment 3 Anshul Behl 2017-01-23 16:39:40 UTC
Please Ignore the last comment as its related to some other bug

Comment 4 MaoPeng 2017-01-24 00:22:30 UTC
is this key.file generated by bz account or sso account ? CWE has stop the  bz account support, and if this is generated by sso account, is it been added as vendor member of that vendor ?

Comment 5 Kun Yan 2017-01-25 02:41:22 UTC
Hi,

I have a workaround for this case. you could regenerated a ci key. 
it should be work.

Thanks,
Kun Yan

Comment 6 Gonéri Le Bouder 2017-01-25 15:27:55 UTC
I regenerated by sandbox_id 3 time in a row with my account (gleboude@redhat.com), but when I try to use it, I always get: "You have not use xmlrpc call to login user bkopilov"

Comment 11 Gonéri Le Bouder 2017-01-26 14:07:32 UTC
Now I get this with my key:

[stack@director ~]$ sudo rhcert-ci run --key-file /home/stack/key.file --debug high

Error: could not get vendor product info from the catalog:
malformed JSON string, neither array, object, number, string or atom, at character offset 0 (before "X[W\x{346}\x{1a9}\x{987b}...") at /usr/lib/perl5/vendor_perl/5.8.8/JSON.pm line 154.

Catalog: https://hardware.redhat.com/xmlrpc.cgi
(Fault code: -32000)
Continue? (yes|no)

Comment 13 Gonéri Le Bouder 2017-01-26 14:27:14 UTC
It works fine know with my key. I think I did some of my test yesterday with a malformed key file. Thanks for you help.

Comment 14 Greg Nichols 2017-01-26 15:05:56 UTC
OK if I close this then?


Note You need to log in before you can comment on or make changes to this bug.