Bug 1415734 - Uninstalling Horizon plugins leaves stale files that result in failure of httpd
Summary: Uninstalling Horizon plugins leaves stale files that result in failure of httpd
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RDO
Classification: Community
Component: openstack-horizon
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: trunk
Assignee: Radomir Dopieralski
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 15:11 UTC by Mohammed Naser
Modified: 2019-12-23 21:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-23 21:01:27 UTC


Attachments (Terms of Use)

Description Mohammed Naser 2017-01-23 15:11:28 UTC
Description of problem:
When uninstalling any plugin (example: openstack-app-catalog-ui), the removal does not make sure that any *.pyc files are removed from `/usr/share/openstack-dashboard/openstack_dashboard/local/enabled/`.  The related `.py` files are removed however, but the `.pyc` are read and cause failures

Version-Release number of selected component (if applicable):
Newton release

How reproducible:


Steps to Reproduce:
1. Install openstack-dashboard
2. Install openstack-app-catalog-ui (or any other UI)
3. Restart httpd
4. Uninstall openstack-app-catalog-ui
5. Restart httpd

Actual results:
The service doesn't start due to errors of missing imports

Expected results:
The service starts with no problem

Additional info:

Comment 1 Radomir Dopieralski 2017-01-23 15:23:00 UTC
That looks like a problem. I wonder if we can find some way to clean up the .pyc files. If not, there is also a way to disable their generation in the first place -- that will make horizon startup time marginally slower, though.

Comment 2 Mohammed Naser 2017-01-24 22:03:06 UTC
The start up is slow enough as is right now as it runs compress+collectstatic on every httpd restart so I don't think it would be that much of a big impact (or will it?)

Comment 3 Christopher Brown 2017-06-22 16:08:44 UTC
Hello Mohammed,

Is this still a problem?

Is it just the (murano?) package the doesn't remove the compiled files or, as appears to be the case, other packages that are also having problems. Do we need to open bugs against all ui components?

Comment 4 Mohammed Naser 2019-12-23 21:01:27 UTC
No longer an issue.


Note You need to log in before you can comment on or make changes to this bug.