Bug 1415742 - rhn-search traceback - immediateTrigger-server exists with certain identification
Summary: rhn-search traceback - immediateTrigger-server exists with certain identific...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhn-client-tools
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Eric Herget
QA Contact: Pavel Studeník
URL:
Whiteboard:
Depends On: 1414579
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 15:35 UTC by Eric Herget
Modified: 2017-06-30 07:48 UTC (History)
8 users (show)

Fixed In Version: rhn-client-tools-2.0.2-16-el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1378441
Environment:
Last Closed: 2017-06-30 07:45:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Eric Herget 2017-01-23 15:36:41 UTC
I mistakenly created this BZ as a Satellite BZ, not RHEL.  This BZ corrects that.

Comment 2 Eric Herget 2017-01-23 15:37:23 UTC
The spacewalk commit for this fix is:
d94017eb49a6161673b6999339d9d6e1d5953612

Comment 3 Eric Herget 2017-02-01 17:53:48 UTC
Regression applied.  The spacewalk commit for this fix is now these two commits:
d94017eb49a6161673b6999339d9d6e1d5953612
eed4b7cf20ff5316a746f9df3ffa70a24c29b206

Comment 8 Pavel Studeník 2017-06-29 12:33:18 UTC
>> rhn_check -vv
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 44, in <module>
    from up2date_client import up2dateAuth
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in <module>
    import rhnserver
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 34, in <module>
    import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 15, in <module>
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 18, in <module>
    from rhn.i18n import sstr
ImportError: No module named i18n


In my opinions this bug and patch should be removed from erratum. Because it is not relevant with RHEL7 and Satellite 5. It is for Spacewalk.

Comment 9 Eric Herget 2017-06-29 18:31:49 UTC
The bug and patch appear to only apply to systems on which we use python 3.  RHEL 7 and RHEL 6 use python 2, so this bug and patch are not necessary.  It is needed on Fedora 25 and higher.

Comment 13 Tomas Lestach 2017-06-30 07:45:08 UTC
This bug does not affect RHEL7. Closing NOTABUG.

Comment 14 Tomas Lestach 2017-06-30 07:48:01 UTC
Eric: The BZ is only necessary on systems where we use python 3.  That should be Fedora 25 and higher, but not RHEL 7 or lower.


Note You need to log in before you can comment on or make changes to this bug.