Bug 1415743 - [UPDATES] Pacemaker cluster is not running after update
Summary: [UPDATES] Pacemaker cluster is not running after update
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Emilien Macchi
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 15:40 UTC by Yurii Prokulevych
Modified: 2017-01-23 15:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-23 15:49:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yurii Prokulevych 2017-01-23 15:40:03 UTC
Description of problem:
-----------------------
After RHOS-11 minor update from 2017-01-18 to 2017-01-20.2 pacemaker is not running on the controller nodes.

pcs status
Error: cluster is not currently running on this node


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
pacemaker-remote-1.1.15-11.el7_3.2.x86_64
pacemaker-cli-1.1.15-11.el7_3.2.x86_64
pacemaker-cluster-libs-1.1.15-11.el7_3.2.x86_64
puppet-pacemaker-0.4.0-1.el7ost.noarch
pacemaker-libs-1.1.15-11.el7_3.2.x86_64
pacemaker-1.1.15-11.el7_3.2.x86_64

python-heat-agent-0.0.1-0.20170109231310.01b1768.el7ost.noarch
openstack-heat-api-cloudwatch-8.0.0-0.20170117101819.f6dcf5a.el7ost.noarch
python-heat-agent-apply-config-0.0.1-0.20170109231310.01b1768.el7ost.noarch
openstack-heat-engine-8.0.0-0.20170117101819.f6dcf5a.el7ost.noarch
python-heat-agent-puppet-0.0.1-0.20170109231310.01b1768.el7ost.noarch
openstack-heat-api-cfn-8.0.0-0.20170117101819.f6dcf5a.el7ost.noarch
puppet-heat-10.1.0-0.20170114060041.19a37b7.el7ost.noarch
python-heatclient-1.7.0-0.20161219135343.5fe6a8b.el7ost.noarch
openstack-heat-api-8.0.0-0.20170117101819.f6dcf5a.el7ost.noarch
python-heat-agent-hiera-0.0.1-0.20170109231310.01b1768.el7ost.noarch
openstack-heat-common-8.0.0-0.20170117101819.f6dcf5a.el7ost.noarch
heat-cfntools-1.3.0-2.el7ost.noarch
python-heat-agent-ansible-0.0.1-0.20170109231310.01b1768.el7ost.noarch

openstack-tripleo-heat-templates-6.0.0-0.20170117185453.cf5e77c.el7ost.noarch
openstack-heat-templates-0.0.1-0.20170109231310.01b1768.el7ost.noarch

Steps to Reproduce:
-------------------
1. Setup latest RHOS-11 repos on undercloud and overcloud

2. Update underloud
    openstack undercloud upgrade

3. Run overcloud update
    yes '' | openstack overcloud update stack -i overcloud

4. Check pacemaker status on overcloud controllers

Additional info:
----------------
Virtual setup: 3controller + 1compute + 3ceph

Comment 2 Lukas Bezdicka 2017-01-23 15:49:42 UTC
I don't see pacemaker as enabled here - probably you have to specify template during deploy to use pacemaker.


Note You need to log in before you can comment on or make changes to this bug.