Bug 1415750 - Heketi DB inconsistent state after heketi pod reboot when some operation in progress
Summary: Heketi DB inconsistent state after heketi pod reboot when some operation in p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: cns-3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: CNS 3.9
Assignee: Michael Adam
QA Contact: krishnaram Karthick
URL:
Whiteboard:
Depends On: 1554219
Blocks: 1526414
TreeView+ depends on / blocked
 
Reported: 2017-01-23 16:09 UTC by Mohamed Ashiq
Modified: 2018-11-20 09:14 UTC (History)
11 users (show)

Fixed In Version: heketi-6.0.0-2.el7rhgs
Doc Type: Bug Fix
Doc Text:
Previously, deleting an heketi pod while some heketi operation was in progress would result in incomplete entries in the database. With this fix, such entries are marked "pending" until the operation is completed thus leading to a consistent database view.
Clone Of:
Environment:
Last Closed: 2018-04-05 03:08:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0638 None None None 2018-04-05 03:09:27 UTC

Description Mohamed Ashiq 2017-01-23 16:09:45 UTC
Description of problem:
Heketi DB inconsistent state after heketi pod reboot when some operation in progress. 

How reproducible:
Always

Steps to Reproduce:
1.Do a volume create 
2. Before end of volume create kill the pod 
3. On start of the heketi pod db is not in good state

Comment 3 Mohamed Ashiq 2017-01-31 16:29:17 UTC
Initial commit upstream:

https://github.com/heketi/heketi/pull/661

Comment 8 krishnaram Karthick 2018-03-12 06:04:19 UTC
Although a fix for this bug is made available in latest cns-deploy build, the same is not available for ansible deployment. 

A bug has been raised for the same in OCP - https://bugzilla.redhat.com/show_bug.cgi?id=1554219

This bug is being moved back to assigned for re-verification with the fix in openshift-ansible.

Comment 9 Humble Chirammal 2018-03-13 11:00:50 UTC
The fix is in merge queue : https://github.com/openshift/openshift-ansible/pull/7494

Comment 10 Humble Chirammal 2018-03-14 08:04:37 UTC
(In reply to Humble Chirammal from comment #9)
> The fix is in merge queue :
> https://github.com/openshift/openshift-ansible/pull/7494

The fix is merged.

Comment 11 Saravanakumar 2018-03-14 10:20:42 UTC
This is targeted for OCP-3.9.z - Refer #1554219

Comment 17 errata-xmlrpc 2018-04-05 03:08:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0638


Note You need to log in before you can comment on or make changes to this bug.