Bug 1415753 - schema.mysql not in rpm
Summary: schema.mysql not in rpm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: opendmarc
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Williamson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1631471 1661531 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 16:11 UTC by Andrew J. Schorr
Modified: 2019-10-26 17:22 UTC (History)
9 users (show)

Fixed In Version: opendmarc-1.3.2-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-19 16:52:36 UTC


Attachments (Terms of Use)

Description Andrew J. Schorr 2017-01-23 16:11:11 UTC
Description of problem:
Why isn't db/schema.mysql included in the package? It seems suboptimal to have to grab the source in order to extract schema.mysql for setting up the database.

Version-Release number of selected component (if applicable):
opendmarc-1.3.2-0.12.el7.x86_64


How reproducible:
rpm -ql opendmarc | grep -i schema


Steps to Reproduce:
1. rpm -ql opendmarc | grep -i schema
2.
3.

Actual results:
No output.


Expected results:
schema.mysql should be in there somewhere, perhaps in doc, where it used to be.

Additional info:

Comment 1 Simone Marchioni 2017-03-07 09:08:05 UTC
Same problem here.

+1

Comment 2 Richard Siddall 2018-04-24 15:42:09 UTC
Might be related to https://sourceforge.net/p/opendmarc/tickets/197/

Comment 3 Simone Marchioni 2018-04-24 17:23:06 UTC
Maybe. But in the actual package installed from EPEL there's no SQL file to create the database. Here's the RPM content:

/etc/opendmarc
/etc/opendmarc.conf
/etc/sysconfig/opendmarc
/etc/tmpfiles.d/opendmarc.conf
/usr/lib/systemd/system/opendmarc.service
/usr/sbin/opendmarc
/usr/sbin/opendmarc-check
/usr/sbin/opendmarc-expire
/usr/sbin/opendmarc-import
/usr/sbin/opendmarc-importstats
/usr/sbin/opendmarc-params
/usr/sbin/opendmarc-reports
/usr/share/doc/opendmarc-1.3.2
/usr/share/doc/opendmarc-1.3.2/README
/usr/share/doc/opendmarc-1.3.2/RELEASE_NOTES
/usr/share/licenses/opendmarc-1.3.2
/usr/share/licenses/opendmarc-1.3.2/LICENSE
/usr/share/licenses/opendmarc-1.3.2/LICENSE.Sendmail
/usr/share/man/man5/opendmarc.conf.5.gz
/usr/share/man/man8/opendmarc-check.8.gz
/usr/share/man/man8/opendmarc-expire.8.gz
/usr/share/man/man8/opendmarc-import.8.gz
/usr/share/man/man8/opendmarc-importstats.8.gz
/usr/share/man/man8/opendmarc-params.8.gz
/usr/share/man/man8/opendmarc-reports.8.gz
/usr/share/man/man8/opendmarc.8.gz
/var/run/opendmarc
/var/spool/opendmarc

Probably it can be fixed including reports/mkdb.mysql

Comment 4 Richard Siddall 2018-04-24 17:51:06 UTC
The patch in bug 197 on SourceForge removes reports/mkdb.mysql.  Steve would have to use db/schema.mysql.

Comment 5 Andrew Schorr 2018-04-24 17:56:06 UTC
Which is exactly what I requested in the first place. What's wrong with schema.mysql?

Comment 6 Adam Williamson 2019-10-04 17:46:59 UTC
*** Bug 1661531 has been marked as a duplicate of this bug. ***

Comment 7 Adam Williamson 2019-10-04 17:50:44 UTC
*** Bug 1631471 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2019-10-04 19:08:40 UTC
FEDORA-EPEL-2019-5393542b88 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5393542b88

Comment 9 Fedora Update System 2019-10-04 19:09:21 UTC
FEDORA-EPEL-2019-3bcbd2f338 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-3bcbd2f338

Comment 10 Fedora Update System 2019-10-04 19:10:18 UTC
FEDORA-2019-24b3f84f6e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-24b3f84f6e

Comment 11 Fedora Update System 2019-10-04 19:10:46 UTC
FEDORA-2019-6a2ca74e55 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6a2ca74e55

Comment 12 Fedora Update System 2019-10-04 19:11:10 UTC
FEDORA-2019-e1f0417a24 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e1f0417a24

Comment 13 Fedora Update System 2019-10-04 21:19:29 UTC
opendmarc-1.3.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-3bcbd2f338

Comment 14 Fedora Update System 2019-10-04 22:15:10 UTC
opendmarc-1.3.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-24b3f84f6e

Comment 15 Fedora Update System 2019-10-04 22:51:20 UTC
opendmarc-1.3.2-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6a2ca74e55

Comment 16 Fedora Update System 2019-10-04 23:09:09 UTC
opendmarc-1.3.2-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e1f0417a24

Comment 17 Fedora Update System 2019-10-05 01:24:15 UTC
opendmarc-1.3.2-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5393542b88

Comment 18 Fedora Update System 2019-10-12 01:29:28 UTC
opendmarc-1.3.2-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2019-10-15 22:39:24 UTC
opendmarc-1.3.2-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2019-10-19 16:52:07 UTC
opendmarc-1.3.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2019-10-19 16:52:36 UTC
opendmarc-1.3.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2019-10-26 17:22:23 UTC
opendmarc-1.3.2-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.