Bug 1415763 - [RFE] Make gluster a backend for Openshift Registry.
Summary: [RFE] Make gluster a backend for Openshift Registry.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cns-deploy-tool
Version: cns-3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: CNS 3.5
Assignee: Jose A. Rivera
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks: 1415595
TreeView+ depends on / blocked
 
Reported: 2017-01-23 16:46 UTC by Humble Chirammal
Modified: 2017-04-20 18:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
OpenShift Container Platform provides an integrated registry with storage using an NFS-backed persistent volume that is automatically setup. This feature allows you to replace this with a Red Hat Gluster Storage persistent volume for registry storage. This provides increased reliability, scalability, and failover.
Clone Of:
Environment:
Last Closed: 2017-04-20 18:26:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1421139 0 unspecified CLOSED [Doc RFE] Document how to define a CNS-deployed volume in OpenShift's docker registry as the storage back end for the Op... 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2017:1112 0 normal SHIPPED_LIVE cns-deploy-tool bug fix and enhancement update 2017-04-20 22:25:47 UTC

Internal Links: 1421139

Description Humble Chirammal 2017-01-23 16:46:29 UTC
Description of problem:


*)    Install OCP + CNS
*)    Create a RHGS volume to back the docker registry using Heketi from the OpenShift console/CLI
*)   Set RHGS volume as the storage back-end for the docker registry


ie,RHGS volume should be back-ending the OpenShift registry in a CNS solution




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Prasanth 2017-04-12 15:32:45 UTC
RHGS volume could be used to back-end the OpenShift registry in a CNS solution on following the manual set of instructions.

Marking it as Verified.

Comment 4 Bhavana 2017-04-18 06:27:35 UTC
Edited the doc text slightly for the Errata.

Comment 6 errata-xmlrpc 2017-04-20 18:26:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1112


Note You need to log in before you can comment on or make changes to this bug.