Bug 141578 - switching between X and VT messes up sysfont
switching between X and VT messes up sysfont
Status: CLOSED DUPLICATE of bug 145969
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-12-02 04:18 EST by Ferry Huberts
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:07:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ferry Huberts 2004-12-02 04:18:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When I choose a different system font in /etc/sysconfig/i18n:
and I then switch between X (terminal 7) and a text mode virtual
terminal (f.e. terminal 1), my system font gets messed up. Seems like
it suddenly has a line spacing of 1.5 or 2 lines.

I do not have this problem when I use the default system font.

I have kernel option vga=ext

Version-Release number of selected component (if applicable):
updated system up to dec 1st 2004

How reproducible:

Steps to Reproduce:
1. see description above

Additional info:
Comment 1 Mike A. Harris 2004-12-02 13:28:09 EST
The X server saves the entire state of the video card at X server
startup.  Any time you switch from X back to the console, it
restores this initial state that it saved at startup, even if you
later change the console font or other aspects of the console
video state.  This is normal and expected behaviour.

If you completely quit the X server, and then change the console
video state in any way, and then restart the X server, when you
switch between VTs, the video should be restored as expected.

Please try this and confirm wether it works for you or not.

Thanks in advance.
Comment 2 Ferry Huberts 2004-12-11 06:34:50 EST
I did some more research on different machines. I am not currently at
the machine that has the problem but to my best memory it is as follows.

The machine with the problem has a 2.6.9 stock kernel, and a 865G
chipset, no frame buffer enabled, and kernel commandline option vga=ext.

I suspect the _no_ framebuffer - vga=ext combination. Other machines
that have a framebuffer have no problems. I can change the font as I
like on them.
Comment 3 Dmitry Butskoy 2005-01-18 12:39:53 EST
  Similar problem on "Intel Corp. 82915G" card ("i810" X driver).
  After switching from X to console, console fonts are reset to some
hardware default. Due to this all national (not ascii) symbols disappear.
  Some words about this issue have already appeared on x.org site, see
Comment 4 Mike A. Harris 2005-01-31 23:10:10 EST

*** This bug has been marked as a duplicate of 145969 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:07:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.