Bug 141579 - logwatch truncates file system usage output
logwatch truncates file system usage output
Status: CLOSED DUPLICATE of bug 138285
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Ryska
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 04:22 EST by Antonin Mares
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Mares 2004-12-02 04:22:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
In email recieved every night from logwatch I don't see space usage 
for one filesystem.

Output from logwatch looks like this:
------------------ Disk Space --------------------

/dev/sda1             251M  101M  137M  43% /
/dev/sda2             2.0G  487M  1.4G  26% /usr
/dev/sda5             494M   92M  378M  20% /var
/dev/mapper/datavg-ftplv


The "df" command gives me following output:
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda1               256666    106759    136655  44% /
none                    257320         0    257320   0% /dev/shm
/dev/sda2              2063536    503688   1455024  26% /usr
/dev/sda5               505604     93212    386288  20% /var
/dev/mapper/datavg-ftplv
                     940651248   1927284 890941668   1% /var/ftp

Version-Release number of selected component (if applicable):
logwatch-5.2.2-1

How reproducible:
Didn't try

Steps to Reproduce:

    

Additional info:
Comment 1 bjorn l. 2004-12-02 19:30:31 EST
I have the same problem.

I think the issue is in zz-disk_space, where it executes:
   df -h | grep '^/dev/'

If you wanted to remove the tmpfs entries (which start
with "none" in the listing above), then the following
would work:

   df -h -x tmpfs
Comment 2 Jiri Ryska 2004-12-06 09:17:41 EST

*** This bug has been marked as a duplicate of 138285 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.