Bug 1415820 - [RFE] Add support to qemu-img for resizing with preallocation
Summary: [RFE] Add support to qemu-img for resizing with preallocation
Status: CLOSED DUPLICATE of bug 1414049
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Max Reitz
QA Contact: Ping Li
URL:
Whiteboard:
Keywords: FutureFeature
Depends On: 1475978 1414049
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 19:50 UTC by Ademar Reis
Modified: 2017-07-27 16:57 UTC (History)
17 users (show)

(edit)
Clone Of: 1414049
(edit)
Last Closed: 2017-05-22 21:24:15 UTC


Attachments (Terms of Use)

Description Ademar Reis 2017-01-23 19:50:24 UTC
+++ This bug was initially created as a clone of Bug #1414049 +++

Description of problem:
At the moment qemu-img allows you to specify how image file should be allocated during creation, using 'preallocation' option. Onr of possible choices is using 'falloc' option to fully allocate image file using fallocate(2) call.

Unfortunately, resize operation only supports sparse resizing and there is no way to preallocate new disk space during resize operation. 

It would be nice, if qemu-img will support preallocation during resize with fallocate(2) and, possibly, some fallback preallocation method.

Comment 1 Ping Li 2017-03-14 10:03:02 UTC
Hi Max,

As the flag rhel-7.4.0? is set, qe wonder to know whether the issue will be fixed in rhel 7.4? Then qe can add it to RHEL 7.4 test plan for disk format. Thanks.

Comment 2 Max Reitz 2017-03-15 22:40:29 UTC
Hi pingl,

I'm most certainly working on getting it into 7.4. Considering that the development phase ends on March 28 and upstream qemu is currently occupied with preparing the 2.9 release, it may very well slip to 7.5, however.
So I cannot give a definite response but if I had to decide I would guess it won't make it into 7.4 (since it's an RFE).


Max


Note You need to log in before you can comment on or make changes to this bug.