Bug 141583 - $SRPM isn't set for CORE
Summary: $SRPM isn't set for CORE
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: other   
(Show other bugs)
Version: beta
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rob Landry
QA Contact: Rob Landry
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-02 10:20 UTC by Jay Turner
Modified: 2015-01-08 00:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-29 15:50:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Turner 2004-12-02 10:20:31 UTC
Description of problem:
This one is really, really weird, but with rhr2-rhel4-0.9-14.9e.dummyrun, I'm
seeing the case where CORE fails because it $SRPM isn't defined as anything,
therefore the rpmbuild process fails.

SRPM gets set in MEMORY, and that code gets sourced into CORE, so not sure
what's actually going on or the right fix, besides setting SRPM in CORE.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Rob Landry 2004-12-02 15:47:31 UTC
This is what I ran into yesterday when fixing the other CORE issue;
unfortunately just setting $SRPM doesn't cut it since MEMORY also somehow got
undefined.  FWIW this is the same behaviour that bash 1.x has which makes rhr2
not work on RHEL 2.1 as well.  Unfortunately I think this means that rhr2 is
probably taking advantage of a bash2 bug; the good news is that once this is
sorted perhaps rhr2 will work on RHEL 2.1 as well.

Comment 2 Rob Landry 2004-12-06 21:18:05 UTC
addressed in rhr2-0.9-14.9f; eg. fixed in CVS


Note You need to log in before you can comment on or make changes to this bug.