Bug 1415915 - RFE: An administrator friendly way to determine rebalance completion time
Summary: RFE: An administrator friendly way to determine rebalance completion time
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1396004
Blocks: 1380598 1436681
TreeView+ depends on / blocked
 
Reported: 2017-01-24 04:42 UTC by Nithya Balachandran
Modified: 2017-03-28 12:40 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1396004
Environment:
Last Closed: 2017-03-06 17:44:03 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2017-01-24 04:42:37 UTC
+++ This bug was initially created as a clone of Bug #1396004 +++

+++ This bug was initially created as a clone of Bug #1380598 +++

Description of problem: There is no single command with which an administrator can measure the time to complete rebalance.

Expectation: Enhance "gluster vol vol-name rebalance status" command output to display the approximate time to complete rebalance.

--- Additional comment from Worker Ant on 2016-11-17 03:41:50 EST ---

REVIEW: http://review.gluster.org/15864 (dht/rebalance Estimate time to complete rebalance) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2016-11-17 03:51:07 EST ---

REVIEW: http://review.gluster.org/15864 (dht/rebalance Estimate time to complete rebalance) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2016-11-21 04:52:04 EST ---

REVIEW: http://review.gluster.org/15893 (dht/rebalance Estimate time to complete rebalance) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2016-12-29 05:26:07 EST ---

REVIEW: http://review.gluster.org/15893 (dht/rebalance Estimate time to complete rebalance) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2017-01-16 23:10:56 EST ---

REVIEW: http://review.gluster.org/15893 (dht/rebalance Estimate time to complete rebalance) posted (#3) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2017-01-17 03:45:41 EST ---

REVIEW: http://review.gluster.org/15893 (dht/rebalance Estimate time to complete rebalance) posted (#4) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2017-01-17 05:14:59 EST ---

REVIEW: http://review.gluster.org/15893 (dht/rebalance Estimate time to complete rebalance) posted (#5) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2017-01-17 05:43:17 EST ---

REVIEW: http://review.gluster.org/15893 (dht/rebalance Estimate time to complete rebalance) posted (#6) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2017-01-19 01:09:55 EST ---

REVIEW: http://review.gluster.org/15893 (dht/rebalance Estimate time to complete rebalance) posted (#7) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2017-01-19 23:01:51 EST ---

COMMIT: http://review.gluster.org/15893 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 2edd75ec8de17da89004859375844f60890a4df0
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Jan 17 15:43:47 2017 +0530

    dht/rebalance Estimate time to complete rebalance
    
    The estimates will be logged to the rebalance log on running
    gluster v rebalance <vol> status
    
    Change-Id: I9d51b139cd4c8dfde1ff2c2050720ae606c13fc6
    BUG: 1396004
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/15893
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 1 Worker Ant 2017-01-24 13:22:39 UTC
COMMIT: https://review.gluster.org/16458 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 55dff8a4ff3ba97f3e6071a374ec59011eacbe26
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Jan 17 15:43:47 2017 +0530

    dht/rebalance Estimate time to complete rebalance
    
    The estimates will be logged to the rebalance log on running
    gluster v rebalance <vol> status
    
    > Change-Id: I9d51b139cd4c8dfde1ff2c2050720ae606c13fc6
    > BUG: 1396004
    > Signed-off-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-on: http://review.gluster.org/15893
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    (cherry picked from commit 2edd75ec8de17da89004859375844f60890a4df0)
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    
    Change-Id: I58b0550210149443966798d9a26e73cb598eeb6a
    BUG: 1415915
    Reviewed-on: https://review.gluster.org/16458
    Tested-by: N Balachandran <nbalacha@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 2 Shyamsundar 2017-03-06 17:44:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.