Bug 1415977 - Upgrade from ovirt-node-ng 4.0 to 4.1 failed.
Summary: Upgrade from ovirt-node-ng 4.0 to 4.1 failed.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.0-rc
: ---
Assignee: Ryan Barry
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 09:49 UTC by cshao
Modified: 2017-01-26 04:25 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-26 04:25:55 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)
/var/log/*.*; /tmp/log; sosreport (8.36 MB, application/x-gzip)
2017-01-24 09:49 UTC, cshao
no flags Details

Description cshao 2017-01-24 09:49:32 UTC
Created attachment 1243867 [details]
/var/log/*.*; /tmp/log; sosreport

Description of problem:
Upgrade from 4.0 to 4.1 failed.


Total size: 515 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch                                                                                                                                             1/3 
Error unpacking rpm package ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch
error: unpacking of archive failed on file /usr/share/ovirt-node-ng/image/ovirt-node-ng-4.1.0-0.20170123.0.el7.squashfs.img;5886945e: cpio: read
  Installing : ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch                                                                                                                                      2/3 
error: ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch: install failed
mount: special device /usr/share/ovirt-node-ng/image//ovirt-node-ng-4.1.0-0.20170123.0.el7.squashfs.img does not exist
mount: special device /tmp/tmp.95wcS0W0bc/LiveOS/rootfs.img does not exist
umount: /tmp/tmp.95wcS0W0bc: not mounted
umount: /tmp/tmp.95wcS0W0bc: not mounted
cp: warning: source file ‘/tmp/ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm’ specified more than once
  Erasing    : ovirt-node-ng-image-update-placeholder-4.0.6.1-1.el7.noarch                                                                                                                                     3/3 
  Verifying  : ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch                                                                                                                                      1/3 
  Verifying  : ovirt-node-ng-image-update-placeholder-4.0.6.1-1.el7.noarch                                                                                                                                     2/3 
  Verifying  : ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch                                                                                                                                             3/3 

Installed:
  ovirt-node-ng-image-update.noarch 0:4.1.0-0.8.rc1.el7.centos                                                                                                                                                     

Replaced:
  ovirt-node-ng-image-update-placeholder.noarch 0:4.0.6.1-1.el7                                                                                                                                                    

Failed:
  ovirt-node-ng-image.noarch 0:4.1.0-0.8.rc1.el7.centos                                                                                                                                                            

Complete!

Version-Release number of selected component (if applicable):
Build1
ovirt-node-ng-installer-ovirt-4.0-2017012304.iso
imgbased-0.8.11-0.201612061451git1b9e081.el7.centos.noarch

Build2
ovirt-node-ng-installer-ovirt-4.1-pre-2017012404.iso
ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm
ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1. Install Build1.
2. Download *ovirt-node-ng-image-update*.rpm and *ovirt-node-ng-image*.rpm of Build2,
3. Upgrade to Build2, using "yum install *update*.rpm".
4. Focus on the output.

Actual results:
1. After step3, there is an error occurred, and the upgrade process is stopped.

Expected results:
After step3, upgrade to Build2 successfully.


Additional info:

Comment 1 Ryan Barry 2017-01-24 20:04:26 UTC
I can't reproduce this, and the cpio error leads me to believe that the download package is bad somehow.

Can you please try re-downloading?

Comment 2 cshao 2017-01-25 03:58:03 UTC
(In reply to Ryan Barry from comment #1)
> I can't reproduce this, and the cpio error leads me to believe that the
> download package is bad somehow.
> 
> Can you please try re-downloading?

Ryan,

We always met the problem of frequent interruptions while downloading rpm from jenkins whatever Proxy Services were used. I tried many times but still met the cpio error.

Could you please help to download the upgrade rpms and share to us if it is convenient for you?


We did upgrade testing on upstream build by install below 2 packages, is this correct behavior?

# ll ovirt-node-ng-image*
-rw-r--r--. 1 root root 539658560 Jan 23 12:32 ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch.rpm
-rw-r--r--. 1 root root      3303 Jan 23 16:11 ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm

Thanks a lot.

Comment 3 Yaniv Kaul 2017-01-25 11:01:10 UTC
Isn't there an MD5 or SHA of the package that can be used to verify it is downloaded properly?!

Comment 4 Ryan Barry 2017-01-25 13:07:56 UTC
These were provided separately, but I'd expect the normal RPM signature to fail if it wasn't downloaded properly.

Sums of the packages I grabbed (tagged as 4.1 RC in Jenkins). These were provided separately in an email:

68686bb61702c472bbe56c70ec76ac47  ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch.rpm
17c238d5bbf26de4775a51da57729122  ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm

Chen -

Can you try verifying the package (rpm -K)?

Comment 5 cshao 2017-01-26 04:25:55 UTC
(In reply to Ryan Barry from comment #4)
> These were provided separately, but I'd expect the normal RPM signature to
> fail if it wasn't downloaded properly.
> 
> Sums of the packages I grabbed (tagged as 4.1 RC in Jenkins). These were
> provided separately in an email:
> 
> 68686bb61702c472bbe56c70ec76ac47 
> ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch.rpm
> 17c238d5bbf26de4775a51da57729122 
> ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm
> 
> Chen -
> 
> Can you try verifying the package (rpm -K)?

Ryan,

Seem the upgrade fail due to download issue from jenkins.
# rpm -K ovirt-node-ng-image*
ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch.rpm: sha1 MD5 NOT OK
ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm: sha1 md5 OK

# md5sum ovirt-node-ng-image*
47bd01facb037220e7726f29b38b98b3  ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch.rpm
19347fb366b9cc9e5c4d815bc5a9dc4b  ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm


Re-download from resources.ovirt.org and test result is pass.

# rpm -K ovirt-node-ng-image*
ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch.rpm: RSA sha1 ((MD5) PGP) md5 NOT OK (MISSING KEYS: (MD5) PGP#fe590cb7) 
ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm: RSA sha1 ((MD5) PGP) md5 NOT OK (MISSING KEYS: (MD5) PGP#fe590cb7) 

# md5sum ovirt-node-ng-image*
44598aa98dadfb591c7fb892967442fe  ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch.rpm
dec4fc042aee9898600cc6cb28a4c847  ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm


Test steps:
1. Install upstream 4.0 build (ovirt-node-ng-4.0.6.1-0.20170123.0)
2. Download upstream 4.1 update package: 
ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch.rpm
ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm
3. Upgrade to 4.1, using "yum install *ovirt-node-ng-image*.rpm".
4. Focus on the output.
5. Reboot.

Test result:
Update - PASS



Dependencies Resolved

================================================================================================================================================================================
 Package                                Arch               Version                                Repository                                                               Size
================================================================================================================================================================================
Installing:
 ovirt-node-ng-image                    noarch             4.1.0-0.8.rc1.el7.centos               /ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch                    515 M
 ovirt-node-ng-image-update             noarch             4.1.0-0.8.rc1.el7.centos               /ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch             0.0  
     replacing  ovirt-node-ng-image-update-placeholder.noarch 4.0.6.1-1.el7

Transaction Summary
================================================================================================================================================================================
Install  2 Packages

Total size: 515 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch                                                                                                          1/3 
  Installing : ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch                                                                                                   2/3 
cp: warning: source file ‘/data/ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch.rpm’ specified more than once
  Erasing    : ovirt-node-ng-image-update-placeholder-4.0.6.1-1.el7.noarch                                                                                                  3/3 
  Verifying  : ovirt-node-ng-image-4.1.0-0.8.rc1.el7.centos.noarch                                                                                                          1/3 
  Verifying  : ovirt-node-ng-image-update-4.1.0-0.8.rc1.el7.centos.noarch                                                                                                   2/3 
  Verifying  : ovirt-node-ng-image-update-placeholder-4.0.6.1-1.el7.noarch                                                                                                  3/3 

Installed:
  ovirt-node-ng-image.noarch 0:4.1.0-0.8.rc1.el7.centos                               ovirt-node-ng-image-update.noarch 0:4.1.0-0.8.rc1.el7.centos                              

Replaced:
  ovirt-node-ng-image-update-placeholder.noarch 0:4.0.6.1-1.el7                                                                                                                 

Complete!


# imgbase w
[INFO] You are on ovirt-node-ng-4.1.0-0.20170123.0+1

# imgbase layout
ovirt-node-ng-4.0.6.1-0.20170123.0
 +- ovirt-node-ng-4.0.6.1-0.20170123.0+1
ovirt-node-ng-4.1.0-0.20170123.0
 +- ovirt-node-ng-4.1.0-0.20170123.0+1


Thanks Ryan.
Close this bug.


Note You need to log in before you can comment on or make changes to this bug.