Bug 1415999 (CVE-2017-1000017) - CVE-2017-1000017 phpMyAdmin: SSRF in replication
Summary: CVE-2017-1000017 phpMyAdmin: SSRF in replication
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2017-1000017
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1416003 1416004 1416005 1416006
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 10:53 UTC by Adam Mariš
Modified: 2020-05-20 21:16 UTC (History)
11 users (show)

Fixed In Version: phpMyAdmin 4.6.6, phpMyAdmin 4.4.15.10, phpMyAdmin 4.0.10.19
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-20 21:16:19 UTC


Attachments (Terms of Use)

Description Adam Mariš 2017-01-24 10:53:29 UTC
For a user with appropriate MySQL privileges it was possible to connect to arbitrary host.

Mitigation:

The vulnerability is exposed only to MySQL superusers.

Affected versions:

All 4.6.x versions (prior to 4.6.6), 4.4.x versions (prior to 4.4.15.10), and 4.0.x versions (prior to 4.0.10.19) are affected.

Upstream patches:

https://github.com/phpmyadmin/phpmyadmin/commit/f8ad5bd
https://github.com/phpmyadmin/phpmyadmin/commit/ca8edbc
https://github.com/phpmyadmin/phpmyadmin/commit/695a488

External References:

https://www.phpmyadmin.net/security/PMASA-2017-6/

Comment 2 Adam Mariš 2017-01-24 10:59:57 UTC
Created phpMyAdmin tracking bugs for this issue:

Affects: fedora-all [bug 1416003]
Affects: epel-all [bug 1416004]

Comment 3 Adam Mariš 2017-01-24 11:00:04 UTC
Created phpMyAdmin4 tracking bugs for this issue:

Affects: epel-5 [bug 1416005]

Comment 4 Product Security DevOps Team 2020-05-20 21:16:19 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.