Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416018 - rlWaitForSocket --close - performance problems after recent change
Summary: rlWaitForSocket --close - performance problems after recent change
Keywords:
Status: CLOSED DUPLICATE of bug 1416014
Alias: None
Product: Fedora
Classification: Fedora
Component: beakerlib
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Dalibor Pospíšil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 11:14 UTC by Stanislav Zidek
Modified: 2017-01-24 11:15 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 11:15:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Stanislav Zidek 2017-01-24 11:14:08 UTC
Description of problem:
After fixing bz1388422, new behaviour brings serious performance penalty because of waiting in close_wait state. We are experiencing great difficulties e.g. in our scenario of testing tls libraries' interoperability.

I think the old behaviour (ignoring sockets with TIME_WAIT) should remain as default and users who really want to wait for this should state it explicitly, e.g. with extra argument.

Version-Release number of selected component (if applicable):
beakerlib-1.12-1

How reproducible:
always

Steps to Reproduce:
1. openssl s_server -key .. -cert .. &
2. (echo Q; sleep 3) |openssl s_client -CAfile ..
3. killall openssl
4. netstat -atn |grep 4433
5. rlWaitForSocket --close 4433

Actual results:
...
tcp        0      0 ::1:35176                   ::1:4433                    TIME_WAIT   
... waits for almost a minute

Expected results:
wait ends almost instantly

Comment 1 Dalibor Pospíšil 2017-01-24 11:15:29 UTC

*** This bug has been marked as a duplicate of bug 1416014 ***


Note You need to log in before you can comment on or make changes to this bug.