Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416019 - Gerrit fails to update bugs when patches are sent for review or being merged
Summary: Gerrit fails to update bugs when patches are sent for review or being merged
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 11:15 UTC by Niels de Vos
Modified: 2017-01-24 11:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 11:21:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2017-01-24 11:15:54 UTC
Description of problem:
Since the Gerrit update this weekend, bugs are not updated anymore when patches are posted or when patches get merged.

One of the examples is https://bugzilla.redhat.com/show_bug.cgi?id=1414654 where the patch was merged today. All(?) other recent patches that got posted do not have matching updates in their bugs either. This makes tracking bugs and their fixes almost impossible.

The http://bugs.cloud.gluster.org/ site tries to filter through the Bugzilla comments and matches patches this way. Without updates to Bugzilla the bugs in that site will have incorrect statistics.

Comment 1 Nigel Babu 2017-01-24 11:21:00 UTC
I just tried to run an update manually and got this error:

Server error: <Fault 410: 'You must log in before using this part of Red Hat Bugzilla.'>

Pretty sure this step was working as part of the testing. Anyway, I forced a manual login and it's working now. See: https://bugzilla.redhat.com/show_bug.cgi?id=1390050#c8


Note You need to log in before you can comment on or make changes to this bug.