Bug 1416048 - unable to assign location for more hosts at once via webUI: 414 Request-URI Too Long
Summary: unable to assign location for more hosts at once via webUI: 414 Request-URI T...
Keywords:
Status: CLOSED DUPLICATE of bug 1413747
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 13:22 UTC by Jan Hutař
Modified: 2017-07-19 12:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-19 12:45:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2017-01-24 13:22:04 UTC
Description of problem:
Unable to assign location for more hosts (250 hosts worked, 500 showed the issue; hostnames have about 32 characters each) at once via webUI - getting "414 Request-URI Too Long" and no error displayed


Version-Release number of selected component (if applicable):
satellite-6.2.6-2.0.el7sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Administer -> Settings -> Entries per page: 250
2. Hosts -> All hosts -> select 500 hosts -> Select Action -> Assign Location


Actual results:
Window appears but stays empty and firefox developer console -> network tab shows failed request with error code 414


Expected results:
Should work or there should be useful error message


Additional info:
I guess this will be issue for lots of (all?) actions from "Select Action" menu

This is related to bug 1401237

Comment 1 Pradeep Kumar Surisetty 2017-01-24 13:32:25 UTC
While changing location of hosts, content hosts page loading take 38.39s

Comment 3 Tomer Brisker 2017-07-19 12:45:39 UTC
This is a dupe of BZ1413747. Even though the action is different, the root cause and solution are the same.

*** This bug has been marked as a duplicate of bug 1413747 ***


Note You need to log in before you can comment on or make changes to this bug.