Bug 1416051 - "Could not determine public IP from AWS metadata"
Summary: "Could not determine public IP from AWS metadata"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Derek Carr
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 13:49 UTC by Brendan Mchugh
Modified: 2020-04-15 15:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-04-12 19:10:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description Brendan Mchugh 2017-01-24 13:49:10 UTC
Description of problem:
We're seeing the below error in the logs for several hosts in our Openshift environment.

atomic-openshift-node[2674]: I0102 08:02:51.541574    2674 aws.go:791] Could not determine public IP from AWS metadata.

It is filling up the log at about 10 second intervals.

Version-Release number of selected component (if applicable):
openshift-3.3.1.7-1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
Jan 03 00:37:24 master01 atomic-openshift-node[2674]: I0103 00:37:24.751776    2674 aws.go:791] Could not determine public IP from AWS metadata.
Jan 03 00:37:35 master01 atomic-openshift-node[2674]: I0103 00:37:35.131777    2674 aws.go:791] Could not determine public IP from AWS metadata.
Jan 03 00:37:45 master01 atomic-openshift-node[2674]: I0103 00:37:45.410314    2674 aws.go:791] Could not determine public IP from AWS metadata.


Expected results:



Additional info:
See also https://github.com/kubernetes/kubernetes/issues/23155

Comment 1 Derek Carr 2017-01-31 22:16:40 UTC
Upstream PR:
https://github.com/kubernetes/kubernetes/pull/40763

Comment 2 Derek Carr 2017-02-01 19:41:03 UTC
Origin PR:
https://github.com/openshift/origin/pull/12760

Comment 3 Troy Dawson 2017-02-03 22:44:02 UTC
This has been merged into ocp and is in OCP v3.5.0.16 or newer.

Comment 4 DeShuai Ma 2017-02-04 03:21:14 UTC
Verify on openshift v3.5.0.16+a26133a

Comment 6 errata-xmlrpc 2017-04-12 19:10:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.