Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416070 - OSPD10 + SR-IOV deployment fails while using nic id's in the compute yaml.
Summary: OSPD10 + SR-IOV deployment fails while using nic id's in the compute yaml.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-net-config
Version: 10.0 (Newton)
Hardware: All
OS: Linux
unspecified
high
Target Milestone: z2
: 10.0 (Newton)
Assignee: Saravanan KR
QA Contact: Ziv Greenberg
URL:
Whiteboard:
Depends On: 1409097
Blocks: 1235009
TreeView+ depends on / blocked
 
Reported: 2017-01-24 14:10 UTC by Saravanan KR
Modified: 2017-03-01 13:35 UTC (History)
16 users (show)

Fixed In Version: os-net-config-5.1.0-1.el7ost
Doc Type: Known Issue
Doc Text:
Currently, the Red Hat OpenStack Platform director 10 with SR-IOV overcloud deployment fails when using the NIC IDs (for example, nic1, nic2, nic3 and so on) in the compute.yaml file. As a workaround, you need to use NIC names (for example, ens1f0, ens1f1, ens2f0, and so on) instead of the NIC IDs to ensure the overcloud deployment completes successfully.
Clone Of: 1409097
Environment:
Last Closed: 2017-03-01 13:35:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1653097 0 None None None 2017-01-24 14:10:01 UTC
OpenStack gerrit 415682 0 None None None 2017-01-24 14:10:01 UTC
OpenStack gerrit 424664 0 None None None 2017-01-24 14:27:09 UTC
Red Hat Product Errata RHBA-2017:0357 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 director Bug Fix Advisory 2017-03-01 18:32:13 UTC

Description Saravanan KR 2017-01-24 14:10:02 UTC
+++ This bug was initially created as a clone of Bug #1409097 +++

Description of problem:

As a part of OSPD10 SR-IOV deploymnet, I have configured the compute yaml file (please find it attached) to use nic id's (nic1, nic2, nic3, etc).

The deployment got stuck on step 5 and eventually it fails due to a timeout.
I have established a connection to one of the computes, and found out in "/var/log/messages" that the nics order isn't correct as it should, it have been changed after the creation of the VF's. nic4 should be mapped to ens2f0 and nic5 should be mapped to ens2f1 (see attached image).

I have tried to use nic names (ens1f0, ens1f1, ens2f0, etc) instead of nic id's, and in this case the overcloud deployment finished successfully.  



Version-Release number of selected component (if applicable):
OSPD10 - 1 controller, two computes with SR-IOV enabled.


How reproducible:
Always

Steps to Reproduce:
1. deploy ospd with attached yamls.


Actual results:
deployment fails due to timeout

Expected results:
overcloud deploy should finish successfully


Additional info:
Compute hardware, HPE ProLiant DL380 Gen9 server, HPE Ethernet 10Gb 2-port 560SFP sr-iov nic.

--- Additional comment from Ziv on 2016-12-29 08:01 EST ---



--- Additional comment from Ziv on 2016-12-29 08:04 EST ---



--- Additional comment from Saravanan KR on 2017-01-18 02:25:06 EST ---

Review - https://review.openstack.org/#/c/415682/

Comment 5 Ziv Greenberg 2017-02-20 07:50:53 UTC
I have verified with the new patch - os-net-config-5.1.0-1.el7ost, deployment finished successfully.

Comment 7 errata-xmlrpc 2017-03-01 13:35:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0357.html


Note You need to log in before you can comment on or make changes to this bug.