Bug 1416081 - custom search fields not mapping to named fields
Summary: custom search fields not mapping to named fields
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Extensions
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: 5.0-RH7
Assignee: Jeff Fearn 🐞
QA Contact: Lianghui Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 14:29 UTC by Scott Lewis
Modified: 2019-09-10 22:20 UTC (History)
3 users (show)

Fixed In Version: 5.0.4-rh29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-10 22:20:05 UTC


Attachments (Terms of Use)

Description Scott Lewis 2017-01-24 14:29:45 UTC
Description of problem:
https://bugzilla.redhat.com/page.cgi?id=ruleengine/details/index.html&rule_name=openstack-remove-TR12
When trying to create a new Rules Engine rule, I am searching for when Target Release is set to a specific number (12 in this case), and have a few other criteria, then I set the TR to "---". I get an error that I didn't check that TR wasn't already "---", even though I had set it to check for TR = 12. Since TR cannot be a value and "---" at the same time, it seems this is an erroneous error message. I've gotten around it by setting a second rule to check if TR is not "---" in addition to TR = 12. 

Version-Release number of selected component (if applicable):


How reproducible: Always

Comment 1 Jeff Fearn 🐞 2017-05-04 05:30:27 UTC
Needs an extra check to see if one of the custom search fields matches the field being changed.

Comment 2 Lianghui Yu 2019-09-03 06:59:54 UTC
Take

Comment 3 Lianghui Yu 2019-09-03 07:46:49 UTC
Verified on latest QE environment,
now Custom field in rule engine is working as criteria correctly.
But field TR --- is not detected as the same.
I think we should use custom field in that way.
Result: PASS

Comment 5 Jeff Fearn 🐞 2019-09-08 22:18:46 UTC
This change has been deployed to the pre-production infrastructure at https://partner-bugzilla.redhat.com

Comment 6 Jeff Fearn 🐞 2019-09-10 22:20:05 UTC
This change is now live. If there are any issues, do not reopen this
bug. Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.