Bug 1416083 - During OSP 9 =>10 upgrade, openstack services moved out of pacemaker are not enabled via systemd
Summary: During OSP 9 =>10 upgrade, openstack services moved out of pacemaker are not ...
Keywords:
Status: CLOSED DUPLICATE of bug 1416073
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 10.0 (Newton)
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 14:30 UTC by Chris Paquin
Modified: 2017-02-05 08:36 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 14:47:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
Services on Upgraded Controller (4.31 KB, text/plain)
2017-01-24 14:30 UTC, Chris Paquin
no flags Details

Description Chris Paquin 2017-01-24 14:30:57 UTC
Created attachment 1243941 [details]
Services on Upgraded Controller

Description of problem:
Following the step that includes  "-e /home/stack/templates/environments/major-upgrade-pacemaker.yaml."

Services are removed from pacemaker control, but are not enabled via systemd as they should be.

However, these services are not being enabled via systemd as they should be.


Version-Release number of selected component (if applicable):
10.0

How reproducible:
Upgrade from OSP 9 to 10. 

Steps to Reproduce:
1. Follow upgrade guide for OSP 10
2. Run upgrade step with /home/stack/templates/environments/major-upgrade-pacemaker.yaml.
3. Log into controller run the following "systemctl list-unit-files | grep openstack"

Actual results:
Services are removed from pacemaker control but are not enabled.

Expected results:
Openstack services should be set to enabled 

Additional info:

Comment 1 Chris Paquin 2017-01-24 14:47:38 UTC

*** This bug has been marked as a duplicate of bug 1416073 ***


Note You need to log in before you can comment on or make changes to this bug.