Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416097 - Failed to delete the bundles when deleting a bundle with lot of configuration parameters and versions
Summary: Failed to delete the bundles when deleting a bundle with lot of configuration...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Database, Performance
Version: JON 3.3.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: DR01
: JON 3.3.9
Assignee: Josejulio Martínez
QA Contact: Jeeva Kandasamy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 15:15 UTC by Filip Brychta
Modified: 2017-10-02 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-02 17:21:51 UTC
Type: Bug


Attachments (Terms of Use)
test bundle (2.51 KB, application/zip)
2017-01-24 15:15 UTC, Filip Brychta
no flags Details
verified screenshot (49.24 KB, image/png)
2017-09-06 07:16 UTC, Jeeva Kandasamy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1399125 0 urgent CLOSED Attempt to list bundle versions fails with the message "Failed to find defined bundles...." 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2017:2846 0 normal SHIPPED_LIVE Red Hat JBoss Operations Network 3.3.9 bug fix update 2017-10-02 21:21:28 UTC

Internal Links: 1399125

Description Filip Brychta 2017-01-24 15:15:36 UTC
Created attachment 1243948 [details]
test bundle

Description of problem:
When having a lot of configuration parameters defined in deploy.xml and after a certain number of uploaded bundle versions it takes long time to delete that bundle. It is eventually deleted but err msg 'Failed to delete the bundles' is shown.

Version-Release number of selected component (if applicable):
JON3.3.8.ER01

How reproducible:
2/2

Steps to Reproduce:
1. Create new bundle ( use attached test2.zip )
2. In the deploy.xml change the version number, create new bundle and upload it to the JBoss ON;
3. Repeat step 2 for 10 different bundle versions;
4. Remove the bundle

Actual results:
Failed to delete the bundles - A request timeout has expired after 30000 ms
The bundle is eventually deleted but it takes several minutes (~ 6 minutes in my case)

Expected results:
Error msg should be shown only when the delete operation actually fails. When it takes long time it should not be displayed as failure.

Additional info:
Found when deleting bundle created via repro steps from BZ1399125

Comment 1 Josejulio Martínez 2017-08-16 22:33:06 UTC
commit ae8a9677cb345ad62a41fce331f37d467d650c5e
Merge: 95eea35 1368686
Author: Michael Burman <yak@iki.fi>
Date:   Wed Aug 16 16:32:09 2017 +0300

    Merge pull request #311 from josejulio/bugs/1416097
    
    Bug 1416097 - Failed to delete the bundles when deleting a bundle wit…

commit 136868674135fb3fb6401384f4c84ed49c13c148
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Wed Aug 2 11:40:40 2017 -0500

    Updates view_bundle_list_deleteTakesLongDetail message


commit c7f7a902cefc637f45ff977b20e6fd067575bc82
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Wed Aug 2 10:38:04 2017 -0500

    Bug 1416097 - Failed to delete the bundles when deleting a bundle with lot of configuration parameters and versions
     Added an INFO message telling it takes long to delete a bundle with many parameters and versions.

Comment 3 Simeon Pinder 2017-09-01 15:34:01 UTC
Moving to ON_QA as available for test with the following binary:
http://download.eng.bos.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/133/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip

*NOTE Build represents JON 3.3.9 DR01 build.

Please report issues as you encounter them.

Comment 4 Jeeva Kandasamy 2017-09-06 07:16:43 UTC
Created attachment 1322523 [details]
verified screenshot

Works as mentioned on the fix. Shows INFO message "A request to delete the selected bundles is taking too long". Screenshot is attached.


Version info:
-------------

OS: Fedora 26
Browser: Firefox 55.0.2 (64-bit)

JBoss Operations Network	
Version: 3.3.0.GA Update 09
Build Number: 74b22f5:8c38c0a
GWT Version: 2.5.0
SmartGWT Version: 3.0p

Comment 5 errata-xmlrpc 2017-10-02 17:21:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2846


Note You need to log in before you can comment on or make changes to this bug.