Bug 1416102 - gfid split brains not getting resolved with automatic splitbrain resolution
Summary: gfid split brains not getting resolved with automatic splitbrain resolution
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate
Version: rhgs-3.2
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: ---
Assignee: Karthik U S
QA Contact: Nag Pavan Chilakam
URL:
Whiteboard:
Depends On:
Blocks: 1304593 1430719 RHGS-3.4-GSS-proposed-tracker
TreeView+ depends on / blocked
 
Reported: 2017-01-24 15:26 UTC by Nag Pavan Chilakam
Modified: 2018-11-16 05:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1430719 (view as bug list)
Environment:
Last Closed: 2018-11-16 05:49:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nag Pavan Chilakam 2017-01-24 15:26:29 UTC
Description of problem:
=======================
as part of RFE testing of bz# 1304593 - Split-brain occurring with one cable pull
I tried to check if the gfid split brain gets resolved based on different policies.

However It doesn't get resolved when i set the cluster.favorite-child-policy to mtime







Version-Release number of selected component (if applicable):
=========
3.8.4-11


How reproducible:
=======
always

Steps to Reproduce:
1.set cluster.favorite-child-policy to say mtime
2.create a gfid split brain situation
3.now check if the automatic healing feature resolves this 

the split brain is not resolved and hence IO error on client as below
[root@dhcp35-196 rep]# ll
ls: cannot access f1: Input/output error
total 1
-?????????? ? ?    ?     ?            ? f1

Comment 3 Atin Mukherjee 2017-03-09 14:18:53 UTC
upstream patch : https://review.gluster.org/16878

Comment 6 Atin Mukherjee 2018-11-12 02:23:15 UTC
Isn't the patch already part of 3.4.0? Does it need only qualification? Can we please take this bug to the closure?

Comment 7 Karthik U S 2018-11-13 05:26:15 UTC
Hi Atin,

Even though the patch is part of 3.4.0, the automatic split-brain resolution policy as a feature (BZ #1304593) has failed-qa. It needs some improvements and bug fixes. Currently the feature itself is not qualified. Since this bug is going to be fixed using the same policies, I think it is better to wait for the other issues to be fixed in the feature before qualifying this.

Thanks,
Karthik


Note You need to log in before you can comment on or make changes to this bug.