Bug 1416107 - Can't create VM attached to VMware Standard switch
Summary: Can't create VM attached to VMware Standard switch
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - VMWare
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 15:38 UTC by Perry Gagne
Modified: 2017-01-24 22:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 22:26:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
Foreman debug (884.82 KB, application/x-xz)
2017-01-24 15:38 UTC, Perry Gagne
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 2700 0 None None None 2017-01-24 15:38:31 UTC

Description Perry Gagne 2017-01-24 15:38:31 UTC
Created attachment 1243956 [details]
Foreman debug

Description of problem:
I tried to create a VM on a VMware compute resource and attach it to a network "pgagne-test-net". "pgagne-test-net" was attached to a standard switch on the host jericho.hq.gsslab.rdu.redhat.com. I wa

Version-Release number of selected component (if applicable):


How reproducible: Everytime


Steps to Reproduce:
1. Start with a VMware enviroment with multiple hypervisors. 
2. Add the vcenter as a compute resource
3. In vmware create a standard switch and assoicated network/portgroup (ie pgagne-test-net)
4. Create a vm on the compute resource, and tie the interface of the vm to pgagne-test-net

Actual results:
Error when creating the VM:
"Failed to create a compute toldedo-vmware (VMware) instance pgagne-host1.pgagne-sat.rh-internal: failed to create vm: CannotAccessVmComponent: A component of the virtual machine is not accessible on the host."

Expected results:
VM is created on correct host. 


Additional info: Satellite has no way to specify which host a vm is created on, so there is no way i can think of to workaround this.

Comment 3 Perry Gagne 2017-01-24 22:20:39 UTC
Chris, this is the same issue you ran into with, correct?

Comment 4 Perry Gagne 2017-01-24 22:26:33 UTC
Hmm I tried this with a shared storage array and it seemed to work fine. I will close this for now since it appears it was a config error on my part.


Note You need to log in before you can comment on or make changes to this bug.