Bug 1416121 - https://github.com/xxxxx cannot open git-upload-pack
Summary: https://github.com/xxxxx cannot open git-upload-pack
Keywords:
Status: CLOSED DUPLICATE of bug 1415137
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-egit
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rob
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1712306555;
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 16:10 UTC by Thomas Schmitz
Modified: 2017-01-26 17:14 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-25 17:40:20 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (3.85 KB, text/plain)
2017-01-24 16:10 UTC, Thomas Schmitz
no flags Details

Description Thomas Schmitz 2017-01-24 16:10:38 UTC
Description of problem:
Pulled from a private repo

Version-Release number of selected component:
eclipse-egit-4.6.0-1.fc25

Additional info:
reporter:       libreport-2.8.0
cmdline:        /usr/bin/java -Dosgi.requiredJavaVersion=1.8 -Xms512m -Xmx1024m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -Dosgi.framework.extensions=org.eclipse.wst.jsdt.nashorn.extension -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.201.v20170109-1424.jar -os linux -ws gtk -arch x86_64 -showsplash /usr/lib64/eclipse//plugins/org.eclipse.platform_4.6.2.v20170109-1424/splash.bmp -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.401.v20170109-1424/eclipse_1618.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.201.v20170109-1424.jar -protect master --launcher.appendVmargs -exitdata 230009 -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.8 -Xms512m -Xmx1024m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -Dosgi.framework.extensions=org.eclipse.wst.jsdt.nashorn.extension -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.201.v20170109-1424.jar
eclipseplugin:  org.eclipse.egit.ui
executable:     /usr/lib64/eclipse/../../share/eclipse/droplets/egit-egit/eclipse/plugins/org.eclipse.egit.ui_4.6.0.201612231935-r.jar
kernel:         4.9.5-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           libreport
uid:            1000

Truncated backtrace:
org.eclipse.jgit.api.errors.TransportException: https://github.com/xxxxxxxxx: cannot open git-upload-pack
	at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:135)
	at org.eclipse.jgit.api.PullCommand.call(PullCommand.java:280)
	at org.eclipse.egit.core.op.PullOperation$1.run(PullOperation.java:200)
	at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
	at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
	at org.eclipse.egit.core.op.PullOperation.execute(PullOperation.java:232)
	at org.eclipse.egit.ui.internal.pull.PullOperationUI.execute(PullOperationUI.java:176)
	at org.eclipse.egit.ui.internal.pull.PullOperationUI.access$0(PullOperationUI.java:168)
	at org.eclipse.egit.ui.internal.pull.PullOperationUI$1.runInWorkspace(PullOperationUI.java:141)
	at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:39)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: org.eclipse.jgit.errors.TransportException: https://github.com/xxxxxxxx: cannot open git-upload-pack
	at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:551)
	at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:311)
	at org.eclipse.jgit.transport.FetchProcess.executeImp(FetchProcess.java:136)
	at org.eclipse.jgit.transport.FetchProcess.execute(FetchProcess.java:122)
	at org.eclipse.jgit.transport.Transport.fetch(Transport.java:1201)
	at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:128)
	... 10 more
Caused by: javax.net.ssl.SSLException: java.security.ProviderException: java.lang.NegativeArraySizeException
	at sun.security.ssl.Alerts.getSSLException(Alerts.java:208)
	at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1949)
	at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1906)
	at sun.security.ssl.SSLSocketImpl.handleException(SSLSocketImpl.java:1889)
	at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1410)
	at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387)
	at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559)
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1546)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1474)
	at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:338)
	at org.eclipse.jgit.transport.http.JDKHttpConnection.getResponseCode(JDKHttpConnection.java:98)
	at org.eclipse.jgit.util.HttpSupport.response(HttpSupport.java:196)
	at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:489)
	... 15 more
Caused by: java.security.ProviderException: java.lang.NegativeArraySizeException
	at sun.security.ec.ECKeyPairGenerator.generateKeyPair(ECKeyPairGenerator.java:147)
	at java.security.KeyPairGenerator$Delegate.generateKeyPair(KeyPairGenerator.java:703)
	at sun.security.ssl.ECDHCrypt.<init>(ECDHCrypt.java:77)
	at sun.security.ssl.ClientHandshaker.serverKeyExchange(ClientHandshaker.java:721)
	at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:281)
	at sun.security.ssl.Handshaker.processLoop(Handshaker.java:979)
	at sun.security.ssl.Handshaker.process_record(Handshaker.java:914)
	at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1062)
	at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1375)
	at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403)
	... 25 more
Caused by: java.lang.NegativeArraySizeException
	at sun.security.ec.ECKeyPairGenerator.generateECKeyPair(Native Method)
	at sun.security.ec.ECKeyPairGenerator.generateKeyPair(ECKeyPairGenerator.java:128)
	... 34 more

Comment 1 Thomas Schmitz 2017-01-24 16:10:39 UTC
Created attachment 1243973 [details]
File: backtrace

Comment 2 Roland Grunberg 2017-01-24 16:55:43 UTC
This seems similar to Bug 1329342 . What version of java-1.8.0-openjdk are you using ?

Comment 3 Mat Booth 2017-01-25 12:13:53 UTC
(In reply to Roland Grunberg from comment #2)
> This seems similar to Bug 1329342 . What version of java-1.8.0-openjdk are
> you using ?

In fact on my machine this seems reproducible using Jiri's HttpsCheck reproduction case from that bug:

$ cat HttpsCheck.java 
import java.io.BufferedReader;
import java.io.BufferedWriter;
import java.io.InputStream;
import java.io.InputStreamReader;
import java.net.URL;

public class HttpsCheck {
    static String[] urls = {
    "https://bugzilla.redhat.com/",
    "https://dl.bintray.com/fabioz/pydev/4.5.5/"};

    public static void main(String[] args) throws Exception{
        for (String url : urls) {
            URL u = new URL(url);
            InputStream is = u.openStream();
            BufferedReader bw = new BufferedReader(new InputStreamReader(is,"utf8"));
            StringBuilder page = new StringBuilder();
            while(true){
                String s = bw.readLine();
                if (s == null){
                    break;
                }
                page.append(s);
            }
            System.out.println(page.toString());
        }
    }    
}
$ javac HttpsCheck.java 
$ java -cp . HttpsCheck
Exception in thread "main" javax.net.ssl.SSLException: java.security.ProviderException: java.lang.NegativeArraySizeException
        at sun.security.ssl.Alerts.getSSLException(Alerts.java:208)
        at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1949)
        at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1906)
        at sun.security.ssl.SSLSocketImpl.handleException(SSLSocketImpl.java:1889)
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1410)
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387)
        at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559)
        at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1546)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1474)
        at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
        at java.net.URL.openStream(URL.java:1045)
        at HttpsCheck.main(HttpsCheck.java:15)
Caused by: java.security.ProviderException: java.lang.NegativeArraySizeException
        at sun.security.ec.ECKeyPairGenerator.generateKeyPair(ECKeyPairGenerator.java:147)
        at java.security.KeyPairGenerator$Delegate.generateKeyPair(KeyPairGenerator.java:703)
        at sun.security.ssl.ECDHCrypt.<init>(ECDHCrypt.java:77)
        at sun.security.ssl.ClientHandshaker.serverKeyExchange(ClientHandshaker.java:721)
        at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:281)
        at sun.security.ssl.Handshaker.processLoop(Handshaker.java:979)
        at sun.security.ssl.Handshaker.process_record(Handshaker.java:914)
        at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1062)
        at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1375)
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403)
        ... 8 more
Caused by: java.lang.NegativeArraySizeException
        at sun.security.ec.ECKeyPairGenerator.generateECKeyPair(Native Method)
        at sun.security.ec.ECKeyPairGenerator.generateKeyPair(ECKeyPairGenerator.java:128)
        ... 17 more


So it seems not to be an Eclipse-specific problem...

Comment 4 Mat Booth 2017-01-25 12:16:25 UTC
I forgot to mention my JDK version:

java-1.8.0-openjdk-1.8.0.111-5.b16.fc25.x86_64

Comment 5 Mat Booth 2017-01-25 12:19:21 UTC
The workaround for me is to downgrade nss:

$ sudo dnf downgrade nss\*

Then the problem goes away. Thomas, can you try and see if this also fixes the problem for you?

Comment 6 Mat Booth 2017-01-25 12:35:47 UTC
OR, as an alternative getting the latest openjdk build also seems to fix the problem: https://koji.fedoraproject.org/koji/buildinfo?buildID=835981

It looks as though it will be available in updates-testing very soon: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4076cf8494

Comment 7 Severin Gehwolf 2017-01-25 14:02:18 UTC
Mat, this is bug 1415137

Comment 8 Roland Grunberg 2017-01-25 17:40:20 UTC
I'm marking this as a duplicate of Bug 1415137.

Recommended workaround is to either download the newer rpms, or enable updates-testing for java-1.8.0-openjdk ( mentioned in comment #6 ). Alternatively one could downgrade nss\* until newer opendjk lands as an update.

*** This bug has been marked as a duplicate of bug 1415137 ***

Comment 9 Thomas Schmitz 2017-01-26 17:14:35 UTC
I did the downgrade and that fixed it for now. Thx


Note You need to log in before you can comment on or make changes to this bug.