Bug 1416131 - Extra certificates in OSP 8.0.3 overcloud image under /etc/pki/product [NEEDINFO]
Summary: Extra certificates in OSP 8.0.3 overcloud image under /etc/pki/product
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director-images
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: async
: 8.0 (Liberty)
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1430466
TreeView+ depends on / blocked
 
Reported: 2017-01-24 16:38 UTC by Peter Kovacs
Modified: 2020-08-13 08:50 UTC (History)
8 users (show)

Fixed In Version: rhosp-director-images-8.0-20170308.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1430466 (view as bug list)
Environment:
Last Closed: 2017-04-04 17:56:51 UTC
Target Upstream Version:
mburns: needinfo? (griveros)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0877 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 director images Bug Fix Advisory 2017-04-04 21:56:30 UTC

Description Peter Kovacs 2017-01-24 16:38:47 UTC
Description of problem:

As of OSP 8.0.3 there's 3 extra certificates in the overcloud image under /etc/pki/product :

-rw-r--r--. 1 root root 2151 Dec  2 14:32 286.pem
-rw-r--r--. 1 root root 2151 Dec  2 14:32 288.pem
-rw-r--r--. 1 root root 2195 Dec  2 14:50 326.pem

Two of these certificates belong to products that are not covered by OSP SKUs and require additional entitlements:

288 = Red Hat Ceph Storage OSD
326 = ? (Red Hat Enterprise Linux Fast Datapath Beta)

As a result node subscription status becomes invalid due to the unentitled products:

# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Invalid

OSP 8.0.1 and 8.0.2 don't include these extra certificates.

Version-Release number of selected component (if applicable):

RHOSP 8.0.3

How reproducible:

Always

Steps to Reproduce:
1. Deploy OSP 8.0.3
2. Register through Satellite or Portal

Actual results:

# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Invalid

Expected results:

# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Current


Additional info:

Comment 6 Mike Burns 2017-03-27 14:58:36 UTC
Fast Datapath is no long in images.

Comment 7 errata-xmlrpc 2017-04-04 17:56:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0877


Note You need to log in before you can comment on or make changes to this bug.