Bug 1416149 - service created via REST API with parent_service is not visible in UI
Summary: service created via REST API with parent_service is not visible in UI
Keywords:
Status: CLOSED DUPLICATE of bug 1444043
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Dan Clarizio
QA Contact: Martin Kourim
URL:
Whiteboard: api:rest:service
Depends On:
Blocks: 1444043
TreeView+ depends on / blocked
 
Reported: 2017-01-24 17:12 UTC by Martin Kourim
Modified: 2017-12-05 15:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1444043 (view as bug list)
Environment:
Last Closed: 2017-06-15 02:31:06 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Kourim 2017-01-24 17:12:50 UTC
Description of problem:
Service created via REST API with reference to an existing service is not visible in UI in service explorer.


Version-Release number of selected component (if applicable):
5.7.0.17


How reproducible:
100%


Steps to Reproduce:
1. create service
2. create service via REST API that reference the service created in Step 1:
POST /api/services
{
  "action" : "create",
  "resource" : {
    "name" : "test_servicea",
    "description" : "Test Service",
    "parent_service" : { "id" : <id> }
  }
}
3. check UI

Comment 2 Martin Kourim 2017-01-26 14:35:23 UTC
Greg McCullough explained to me that it's expected behavior unless the "display" attribute is set to true.

However even when the service is created or edited with "display": true, it is not visible in the UI even after the "Reload current display" button is pressed. Only after browser page refresh the child service is visible in UI.

Comment 3 Martin Kourim 2017-01-26 17:10:03 UTC
Similarly when the child service that is already visible in UI is deleted using REST API, it remains visible until browser page is refreshed - "Reload current display" button alone will not do.

Comment 5 Jillian Tullo 2017-04-20 15:32:32 UTC
After looking at the API, I can see that the requests were made successfully and the services exist. It appears the UI is only displaying services that do not have parents - passing along to the UI team who will be able to provide more information and clarification.

Comment 6 Jillian Tullo 2017-04-20 15:35:15 UTC
After taking a look into the API, it appears to work as expected. The services are created with the correct information and parent references. The UI does not seem to show services with parents, but am passing along to the UI team to take a look and provide further clarification.

Comment 7 lgalis 2017-06-15 02:31:06 UTC

*** This bug has been marked as a duplicate of bug 1444043 ***


Note You need to log in before you can comment on or make changes to this bug.