Bug 141615 - Add multipath-tools to Core
Summary: Add multipath-tools to Core
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-02 15:18 UTC by Rudi Chiarito
Modified: 2014-03-17 02:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 22:15:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rudi Chiarito 2004-12-02 15:18:56 UTC
Description of problem:

Multipath-tools should probably be part of Core. It is more advanced
than the simple-minded mdmpd:

It's not a final release yet, but IMHO it's already worth of getting
some attention by at least Rawhide users.

Additional info:

http://christophe.varoqui.free.fr/wiki/wakka.php?wiki=Home

Comment 1 Rudi Chiarito 2004-12-02 17:46:02 UTC
Am I right in assuming that mp-tools depends on a kernel module (and
thus patches) not in Rawhide/upstream yet?

And mdmpd relies on md while multipathd on dm, right? I guess that
would be another justification for multipath-tools' inclusion.

Those pesky two-letter acronyms... thankfully we have run out of
possible permutations of 'm' and 'd'.

Comment 2 Alasdair Kergon 2004-12-02 17:52:56 UTC
multipath-tools indeed depends on a device-mapper module that is not
yet upstream, but it will probably be submitted within the next couple
of months.

Comment 3 Bill Nottingham 2005-03-02 22:15:41 UTC
Deferring because of kernel dependency.

Comment 4 Alasdair Kergon 2005-03-02 23:17:38 UTC
I have started work on this - I named the package device-mapper-multipath to
avoid confusion with alternative multipath implementations.

I anticipate the kernel patches will be included as of 2.6.12.



Note You need to log in before you can comment on or make changes to this bug.