Bug 1416167 - [RFE] Host collection package installation via katello-agent shows no failed tasks
Summary: [RFE] Host collection package installation via katello-agent shows no failed ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Tasks Plugin
Version: 6.2.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 18:15 UTC by Taft Sanders
Modified: 2020-04-15 15:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-16 12:37:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1316598 0 high CLOSED [RFE] Satellite 6.2 Remote Execution provider not based on SSH-keys 2021-03-11 14:30:57 UTC

Internal Links: 1316598

Description Taft Sanders 2017-01-24 18:15:05 UTC
Description of problem:
When using host collection to install packages/errata on a collection of clients. Tasks are created to reflect the clients that successfully applied updates. But no tasks are created for clients that fail to update.

Version-Release number of selected component (if applicable):
Satellite 6.2.6

How reproducible:
Everytime

Steps to Reproduce:
1. Create, Register client with needed errata to Satellite server
2. Turn goferd off on the client
3. Create host collection with client as a member and push updates/errata

Actual results:
0 tasks in the Satellite webui are created to reflect the action was actually accepted. No task will reflect that certain clients from the host collection did not accept the action.

Expected results:
Much like bulk actions, I would expect to see 1 task for the host collection with several sub tasks showing each clients push and a summary to show how many clients accepted and how many failed.


Additional info:
I feel it's important to note that upon testing this, that even after leaving goferd off on the client for more than 10 mins (content_action_accept_timeout =20secs) the host still picked up the "seemingly non-existent" task and applied the packages/errata applicable to the task that was initiated. It would seem that even if the task doesn't complete on the client that it can still be initiated if the client issue is resolved to pick up tasks from the Satellite.

This RFE relates much to bug 1402469 (https://bugzilla.redhat.com/show_bug.cgi?id=1402469).

Comment 1 Taft Sanders 2017-01-24 18:19:23 UTC
Possible duplicate RFE:
Bug 1192889 – [RFE] Task section for Host collection with Satellite Web-UI.
https://bugzilla.redhat.com/show_bug.cgi?id=1192889

Sorry just found this after making this bug. Please confirm if this is a duplicate to the above RFE.

Comment 2 Adam Ruzicka 2018-08-16 12:37:57 UTC
When a package is installed/updated on a host, the host sends its package profile (among other things) to Satellite. In Satellite we create a task to process the data sent by the host asynchronously. That means the task gets created purely as a reaction to a thing happening to the host.

When you install/update a package using the katello-agent, on Satellite's side we just put a message onto a message bus and we don't create no task at all. The host listens on the message bus, reads the message, acts accordingly (installs/updates package) and if the installation succeeds it sends the package profile to Satellite, where a task gets created.

For this reason, you only get tasks for successful installations, because tasks are just a reaction to successful installation, if the installation fails, no report gets sent.

Alternative to this would be doing the package actions using remote execution, especially once we have a non-SSH based provider (BZ1316598). 

I'm closing this as a WONTFIX, please feel free to reopen this BZ if you feel strongly about this.


Note You need to log in before you can comment on or make changes to this bug.