Bug 1416179 - openstack-gnocchi-metricd fails to start
Summary: openstack-gnocchi-metricd fails to start
Keywords:
Status: CLOSED DUPLICATE of bug 1416349
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ga
: 11.0 (Ocata)
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 19:08 UTC by Marius Cornea
Modified: 2017-01-25 11:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-25 11:45:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marius Cornea 2017-01-24 19:08:10 UTC
Description of problem:
openstack-gnocchi-metricd. fails to start:

CRITICAL gnocchi [-] TypeError: unsupported operand type(s) for +: 'int' and 'NoneType'
ERROR gnocchi Traceback (most recent call last):
ERROR gnocchi   File "/usr/bin/gnocchi-metricd", line 10, in <module>
ERROR gnocchi     sys.exit(metricd())
ERROR gnocchi   File "/usr/lib/python2.7/site-packages/gnocchi/cli.py", line 299, in metricd
ERROR gnocchi     MetricdServiceManager(conf).run()
ERROR gnocchi   File "/usr/lib/python2.7/site-packages/gnocchi/cli.py", line 293, in run
ERROR gnocchi     super(MetricdServiceManager, self).run()
ERROR gnocchi   File "/usr/lib/python2.7/site-packages/cotyledon/_service_manager.py", line 205, in run
ERROR gnocchi     self._wait_forever()
ERROR gnocchi   File "/usr/lib/python2.7/site-packages/cotyledon/_utils.py", line 148, in _wait_forever
ERROR gnocchi     self._on_wakeup()
ERROR gnocchi   File "/usr/lib/python2.7/site-packages/cotyledon/_service_manager.py", line 213, in _on_wakeup
ERROR gnocchi     self._adjust_workers()
ERROR gnocchi   File "/usr/lib/python2.7/site-packages/cotyledon/_service_manager.py", line 279, in _adjust_workers
ERROR gnocchi     self._start_worker(service_id, worker_id)
ERROR gnocchi   File "/usr/lib/python2.7/site-packages/cotyledon/_service_manager.py", line 329, in _start_worker
ERROR gnocchi     self._slowdown_respawn_if_needed()
ERROR gnocchi   File "/usr/lib/python2.7/site-packages/cotyledon/_service_manager.py", line 320, in _slowdown_respawn_if_needed
ERROR gnocchi     expected_children = sum(s.workers for s in self._services.values())
ERROR gnocchi TypeError: unsupported operand type(s) for +: 'int' and 'NoneType'


Version-Release number of selected component (if applicable):
openstack-gnocchi-carbonara-3.0.4-0.20170115190654.ed2a370.el7ost.noarch
python-gnocchiclient-2.8.1-0.20170113103203.0691083.el7ost.noarch
openstack-gnocchi-common-3.0.4-0.20170115190654.ed2a370.el7ost.noarch
openstack-gnocchi-metricd-3.0.4-0.20170115190654.ed2a370.el7ost.noarch
puppet-gnocchi-10.1.0-0.20170114055847.6f99891.el7ost.noarch
python-gnocchi-3.0.4-0.20170115190654.ed2a370.el7ost.noarch
openstack-gnocchi-api-3.0.4-0.20170115190654.ed2a370.el7ost.noarch
openstack-gnocchi-indexer-sqlalchemy-3.0.4-0.20170115190654.ed2a370.el7ost.noarch
openstack-gnocchi-statsd-3.0.4-0.20170115190654.ed2a370.el7ost.noarch


How reproducible:


Steps to Reproduce:
1. Deploy overcloud with Gnocchi services running on custom role

Actual results:
openstack-gnocchi-metricd fails to start

Expected results:
openstack-gnocchi-metricd gets started

Additional info:
[root@overcloud-serviceapi-0 heat-admin]# grep -v ^# /etc/gnocchi/gnocchi.conf | grep -v ^$
[DEFAULT]
log_dir = /var/log/gnocchi
[api]
max_limit = 1000
host=overcloud-serviceapi-0.internalapi.localdomain
port=8041
workers=2
[archive_policy]
[cors]
[cors.subdomain]
[database]
[indexer]
url = mysql+pymysql://gnocchi:DXP7sXTCfpwRZjKpNZVgCVkGB@10.0.0.18/gnocchi?bind_address=
[metricd]
workers = 
[oslo_middleware]
enable_proxy_headers_parsing = True
[oslo_policy]
policy_file = /etc/gnocchi/policy.json
[statsd]
resource_id = 0a8b55df-f90f-491c-8cb9-7cdecec6fc26
user_id = 27c0d3f8-e7ee-42f0-8317-72237d1c5ae3
project_id = 6c38cd8d-099a-4cb2-aecf-17be688e8616
archive_policy_name = low
flush_delay = 10
[storage]
coordination_url = redis://:cx3vV923fK8qmnHYbcQPXyBnu@10.0.0.13:6379/
driver = ceph
ceph_pool = metrics
ceph_username = openstack
ceph_keyring = /etc/ceph/ceph.client.openstack.keyring
ceph_conffile = /etc/ceph/ceph.conf
[keystone_authtoken]
auth_uri=http://10.0.0.18:5000/v2.0
auth_type=password
auth_url=http://192.168.0.14:35357
username=gnocchi
password=DXP7sXTCfpwRZjKpNZVgCVkGB
user_domain_name=Default
project_name=service
project_domain_name=Default

Comment 1 Marius Cornea 2017-01-25 11:45:21 UTC

*** This bug has been marked as a duplicate of bug 1416349 ***


Note You need to log in before you can comment on or make changes to this bug.