Bug 1416195 - python(2)-bloom seems to have a broken dependency
Summary: python(2)-bloom seems to have a broken dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-bloom
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Scott K Logan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 20:03 UTC by Tomas Toth
Modified: 2017-02-06 01:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-05 05:19:12 UTC
Type: Bug


Attachments (Terms of Use)
Output of: dnf -v --debugsolver update (9.30 MB, application/x-tar)
2017-01-24 20:03 UTC, Tomas Toth
no flags Details

Description Tomas Toth 2017-01-24 20:03:48 UTC
Created attachment 1244072 [details]
Output of: dnf -v --debugsolver update

Description of problem:
Cannot update/obsolete python-bloom.noarch by python2-bloom.noarch.

# dnf check-update 
Last metadata expiration check: 0:11:35 ago on Tue Jan 24 20:43:28 2017.
Obsoleting Packages
python2-bloom.noarch       0.5.23-1.fc25     updates      
    python-bloom.noarch    0.5.21-1.fc25     @@commandline

# dnf update
Last metadata expiration check: 0:11:55 ago on Tue Jan 24 20:43:28 2017.
Dependencies resolved.
Nothing to do.
Complete!


Expected results:
python-bloom.noarch get updated to python2-bloom.noarch.


Additional info:
# dnf -v --debugsolver update            
cachedir: /var/cache/dnf
Loaded plugins: copr, leaves, debuginfo-install, Query, builddep, protected_packages, show-leaves, reposync, needs-restarting, generate_completion_cache, system-upgrade, config-manager, noroot, playground, download
DNF version: 1.1.10
repo: using cache for: rpmfusion-free-updates
not found deltainfo for: RPM Fusion for Fedora 25 - Free - Updates
not found updateinfo for: RPM Fusion for Fedora 25 - Free - Updates
repo: using cache for: adobe-linux-x86_64
not found deltainfo for: Adobe Systems Incorporated
not found updateinfo for: Adobe Systems Incorporated
repo: using cache for: rpmfusion-nonfree-updates
not found deltainfo for: RPM Fusion for Fedora 25 - Nonfree - Updates
not found updateinfo for: RPM Fusion for Fedora 25 - Nonfree - Updates
repo: using cache for: fedora-cisco-openh264
not found updateinfo for: Fedora 25 openh264 (From Cisco) - x86_64
repo: using cache for: rpmfusion-free
not found deltainfo for: RPM Fusion for Fedora 25 - Free
not found updateinfo for: RPM Fusion for Fedora 25 - Free
repo: using cache for: fedora
not found updateinfo for: Fedora 25 - x86_64
repo: using cache for: rpmfusion-nonfree
not found deltainfo for: RPM Fusion for Fedora 25 - Nonfree
not found updateinfo for: RPM Fusion for Fedora 25 - Nonfree
repo: using cache for: updates
rpmfusion-free-updates: using metadata from Fri Jan 20 19:11:27 2017.
adobe-linux-x86_64: using metadata from Wed Jan  4 19:13:31 2017.
rpmfusion-nonfree-updates: using metadata from Fri Jan 20 19:15:48 2017.
fedora-cisco-openh264: using metadata from Mon Aug 15 18:30:50 2016.
rpmfusion-free: using metadata from Sat Nov 19 00:41:21 2016.
fedora: using metadata from Tue Nov 15 20:49:18 2016.
rpmfusion-nonfree: using metadata from Sat Nov 19 09:27:15 2016.
updates: using metadata from Tue Jan 24 03:37:47 2017.
Last metadata expiration check: 0:14:31 ago on Tue Jan 24 20:43:28 2017.
--> Starting dependency resolution
--> Finished dependency resolution
Dependencies resolved.
Nothing to do.
Completion plugin: Generating completion cache...
Complete!

Comment 1 Rich Mattes 2017-01-26 22:48:36 UTC
I think the problem is that python-bloom depends on python2-rosdep, but I forgot to push the update that provides python2-rosdep to f25 and f24.

I'm building updates to rosdep now that should solve the issue.

Comment 2 Fedora Update System 2017-01-26 22:59:28 UTC
python-rosdep-0.11.4-6.fc24 python-rosdep-0.11.4-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7c53daa8af

Comment 3 Tomas Toth 2017-01-27 00:25:49 UTC
python2-rosdep-0.11.4-6.fc24.noarch fixed the dependency issue.
Thanks.

Comment 4 Rich Mattes 2017-01-27 03:09:35 UTC
Good to know, thanks!  Sorry for the inconvenience!

Comment 5 Fedora Update System 2017-01-27 03:13:27 UTC
python-rosdep-0.11.4-6.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8e28b30ac1

Comment 6 Fedora Update System 2017-01-28 04:55:36 UTC
python-rosdep-0.11.4-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8e28b30ac1

Comment 7 Fedora Update System 2017-01-29 02:21:07 UTC
python-rosdep-0.11.4-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7c53daa8af

Comment 8 Tomas Toth 2017-01-30 18:56:40 UTC
The python-rosdep-0.11.4-6.fc25 installed fine, too.

Comment 9 Fedora Update System 2017-02-05 05:19:12 UTC
python-rosdep-0.11.4-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-02-06 01:48:54 UTC
python-rosdep-0.11.4-6.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.