Bug 1416198 - after update rawhide doesn't finish booting
Summary: after update rawhide doesn't finish booting
Keywords:
Status: CLOSED DUPLICATE of bug 1415358
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 20:43 UTC by Veteran
Modified: 2017-01-31 22:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-30 15:45:47 UTC
Type: Bug


Attachments (Terms of Use)
packages skipped (15.43 KB, text/plain)
2017-01-24 20:49 UTC, Veteran
no flags Details

Description Veteran 2017-01-24 20:43:40 UTC
Description of problem:

When upgrading rawhide (dnf upgrade --refresh) I get a machine which never finishes booting, not even from the rescue kernel (eventually get Give root password for maintenance IF booting rescue kernel) Otherwise, machine must be hard powered off. Rescue kernel eventually boots to very minimal cli functionality.

After update completes, and then reboot:

systemd-journald failed to create notify socket: protocol not supported
A start job is running for journal service
A start job is running to kernel device manager
A start job is running for ...droot.device

failed to start journal service
failed to start udev kernel device manager
  see systemctl status systemd-udev.service

Just continues trying these repeatedly

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. disabled selinux, turned off screensaver
2. dnf upgrade
3. reboot

Actual results:
update paused here but then cotinued

  Erasing     : kernel-modules-4.9.0-0.rc0.git9.1.fc26.i686             315/401
  Erasing     : kernel-core-4.9.0-0.rc0.git9.1.fc26.i686                316/401
warning: file /lib/modules/4.9.0-0.rc0.git9.1.fc26.i686/updates: remove failed: No such file or directory
  Cleanup     : systemd-udev-231-11.fc26.i686                           317/401

machine is a virtualbox vm. I am updating this after creating a snapshot so I can go back to a known good machine.

update completes, then reboot

systemd-journald failed to create notify socket: protocol not supported
A start job is running for journal service
A start job is running to kernel device manager
A start job is running for ...droot.device

failed to start journal service
failed to start udev kernel device manager
  see systemctl status systemd-udev.service

Just continues trying these services repeatedly and failing


Expected results:
Machine boots to lxde login screen

Additional info:
update paused here but then continued

  Erasing     : kernel-modules-4.9.0-0.rc0.git9.1.fc26.i686             315/401
  Erasing     : kernel-core-4.9.0-0.rc0.git9.1.fc26.i686                316/401
warning: file /lib/modules/4.9.0-0.rc0.git9.1.fc26.i686/updates: remove failed: No such file or directory
  Cleanup     : systemd-udev-231-11.fc26.i686                           317/401

machine is a virtualbox vm. I am updating this after creating a snapshot so I can go back to a known good machine.

WHEN DOING UPDATE If I exclude systemd-udev, about half the updates get missed because of broken dependencies but the machine boots.

Comment 1 Veteran 2017-01-24 20:47:43 UTC
pre-update systemd is systemd-231-11.fc26.i686

Comment 2 Veteran 2017-01-24 20:49:14 UTC
Created attachment 1244086 [details]
packages skipped

These packages get skipped when I exclude

exclude=kernel* systemd-udev* python3-pyudev* system-config-printer-udev*

Comment 3 Zbigniew Jędrzejewski-Szmek 2017-01-30 15:45:47 UTC
Should be fixed now. Please test the latest build.

*** This bug has been marked as a duplicate of bug 1415358 ***

Comment 4 Veteran 2017-01-31 22:01:15 UTC
Yes thank you this fixes it


Note You need to log in before you can comment on or make changes to this bug.