Bug 1416244 - Xwayland crashes when using joystick to keyboard emulation
Summary: Xwayland crashes when using joystick to keyboard emulation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 03:16 UTC by penguinbait
Modified: 2017-04-12 01:52 UTC (History)
4 users (show)

Fixed In Version: xorg-x11-server-1.19.3-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-01 00:25:35 UTC
Type: Bug


Attachments (Terms of Use)
rpm -qa / cat /proc/modules | dmesg (159.33 KB, text/plain)
2017-01-25 03:16 UTC, penguinbait
no flags Details
strace attach pid crash output (4.08 KB, text/plain)
2017-01-31 02:24 UTC, penguinbait
no flags Details
Example strace attached to antimicro pid - capture crash (4.08 KB, text/plain)
2017-01-31 02:29 UTC, penguinbait
no flags Details
Example strace attached to Xwayland pid - capture crash (20.02 KB, text/plain)
2017-01-31 02:30 UTC, penguinbait
no flags Details

Description penguinbait 2017-01-25 03:16:58 UTC
Created attachment 1244137 [details]
rpm -qa / cat /proc/modules | dmesg

Description of problem:
Using qjoypad or antimicro, holding down a joystick button which is emulating keyboard keypress xwayland crashes within 10 seconds every time

Version-Release number of selected component (if applicable):
Fedora release 25 (Twenty Five)

[matt.lewis@snoopy ~]$ dnf info antimicro
Last metadata expiration check: 1:11:57 ago on Tue Jan 24 20:36:28 2017.
Installed Packages
Name        : antimicro
Arch        : x86_64
Epoch       : 0
Version     : 2.23
Release     : 1.fc25
Size        : 3.6 M
Repo        : @System
From repo   : updates
Summary     : Graphical program used to map keyboard buttons and mouse controls to a gamepad
URL         : https://github.com/AntiMicro/antimicro
License     : GPLv3+
Description : AntiMicro is a graphical program used to map keyboard keys and mouse controls
            : to a gamepad. This program is useful for playing PC games using a gamepad that
            : do not have any form of built-in gamepad support. AntiMicro was inspired by
            : QJoyPad but has additional features.

[matt.lewis@snoopy ~]$ dnf info qjoypad
Last metadata expiration check: 1:24:02 ago on Tue Jan 24 20:36:28 2017.
Installed Packages
Name        : qjoypad
Arch        : x86_64
Epoch       : 0
Version     : 4.1.0
Release     : 6.1
Size        : 250 k
Repo        : @System
From repo   : @commandline
Summary     : Remap joystick events as keyboard or mouse events
URL         : http://qjoypad.sourceforge.net/
License     : GPL v2.0
Description : qjoypad a simple Linux/QT program that lets you use your gaming devices where you want them: in your games! QJoyPad takes input from a gamepad or joystick and translates it into key strokes or
            : mouse actions, letting you control any XWindows program with your game controller.


[matt.lewis@snoopy ~]$ lspci  | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)


[matt.lewis@snoopy ~]$ rpm -qa | grep -i xorg
xorg-x11-drv-wacom-0.34.0-1.fc25.x86_64
xorg-x11-server-utils-7.7-20.fc25.x86_64
xorg-x11-drv-fbdev-0.4.3-25.fc25.x86_64
xorg-x11-drv-nouveau-1.0.13-1.fc25.x86_64
xorg-x11-xauth-1.0.9-5.fc24.x86_64
xorg-x11-fonts-100dpi-7.5-16.fc24.noarch
xorg-x11-xkb-utils-7.7-17.fc24.x86_64
xorg-x11-fonts-Type1-7.5-16.fc24.noarch
xorg-x11-drv-openchrome-0.5.0-2.fc25.x86_64
xorg-x11-proto-devel-7.7-20.fc25.noarch
xorg-x11-drv-synaptics-1.9.0-1.fc25.x86_64
xorg-x11-drv-vmware-13.2.1-1.fc25.x86_64
xorg-x11-xinit-1.3.4-13.fc25.x86_64
abrt-addon-xorg-2.9.0-1.fc25.x86_64
xorg-x11-drv-intel-2.99.917-26.20160929.fc25.x86_64
xorg-x11-drv-vesa-2.3.2-25.fc25.x86_64
xorg-x11-drv-evdev-2.10.5-1.fc25.x86_64
xorg-x11-server-Xwayland-1.19.1-2.fc25.x86_64
xorg-x11-fonts-75dpi-7.5-16.fc24.noarch
xorg-x11-drv-qxl-0.1.4-10.20160929gite13d28ee.fc25.x86_64
xorg-x11-server-common-1.19.1-2.fc25.x86_64
xorg-x11-drv-libinput-0.23.0-2.fc25.x86_64
xorg-x11-font-utils-7.5-32.fc25.x86_64
xorg-x11-drv-ati-7.7.1-1.20160928git3fc839ff.fc25.x86_64
xorg-x11-utils-7.5-21.fc24.x86_64
xorg-x11-server-Xorg-1.19.1-2.fc25.x86_64

[matt.lewis@snoopy ~]$ rpm -qa | grep -i wayland
qt5-qtwayland-devel-5.7.1-2.fc25.x86_64
wayland-protocols-devel-1.7-1.fc25.noarch
libwayland-server-1.12.0-1.fc25.x86_64
libwayland-client-1.12.0-1.fc25.i686
mesa-libwayland-egl-13.0.3-1.fc25.x86_64
xorg-x11-server-Xwayland-1.19.1-2.fc25.x86_64
qt5-qtwayland-5.7.1-2.fc25.x86_64
libwayland-client-1.12.0-1.fc25.x86_64
wayland-devel-1.12.0-1.fc25.x86_64
libwayland-cursor-1.12.0-1.fc25.x86_64
libwayland-server-1.12.0-1.fc25.i686
gnome-session-wayland-session-3.22.2-3.fc25.x86_64
ibus-wayland-1.5.14-5.fc25.x86_64
mesa-libwayland-egl-devel-13.0.3-1.fc25.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. setup joystick to emulate keypress antimicro or qjoypad
2. hold down joystick button
3. Xwayland crashes

Actual results:
Xwayland crashes


Expected results:
Xwayland not crashing


Additional info:
can be provided upon request

Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE)
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) Backtrace:
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 0: /usr/bin/Xwayland (OsLookupColor+0x139) [0x5909c9]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x7f65cc9f65bf]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 2: /usr/bin/Xwayland (InitOutput+0xcae) [0x426f6e]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 3: /usr/bin/Xwayland (XkbRemoveResourceClient+0xa37) [0x524fe7]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 4: /usr/bin/Xwayland (TimerSet+0x190) [0x58abb0]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 5: /usr/bin/Xwayland (TimerSet+0x208) [0x58ac78]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 6: /usr/bin/Xwayland (WaitForSomething+0x327) [0x58adf7]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 7: /usr/bin/Xwayland (SendErrorToClient+0x13a) [0x55668a]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 8: /usr/bin/Xwayland (InitFonts+0x428) [0x55a898]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 9: /lib64/libc.so.6 (__libc_start_main+0xf1) [0x7f65cc63f401]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 10: /usr/bin/Xwayland (_start+0x2a) [0x423dba]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) 11: ? (?+0x2a) [0x2a]
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE)
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) Segmentation fault at address 0x20
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE)
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: Fatal server error:
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE) Caught signal 11 (Segmentation fault). Server aborting
Jan 24 21:43:01 snoopy org.gnome.Shell.desktop: (EE)

Comment 1 penguinbait 2017-01-26 00:54:52 UTC
I created new user, and was able to reproduce.  I wanted to confirm there was nothing in my profile causing the issue.  This is on a laptop, I am unable to confirm on my desktop.  The only notable differences I can think of is it has an Nvidia low end graphics card running Nvidia drivers.  Also joystick is plugged into usb 2.0, and laptop only has 3.0.

Comment 2 penguinbait 2017-01-30 02:43:05 UTC
I have tested this as multiple users, including root and all exhibit the same behavior.  One thing I did notice, is if I load antimicro or qjoypad and setup keys, I can join a game and they will work, until I hold a key to long and then it crashes.  However doing this on the command line does not result in any keys being pressed in the terminal.  

However if as root I run startx manually it works in the terminal and no crash or errors are seen.  

I am happy to provide any more information if requested

Comment 3 penguinbait 2017-01-30 03:01:35 UTC
Well, I wanted to confirm this was not something stupid I have done.  So I booted to the F25 Live image on USB.  I installed antimicro.  I set one button to a keyboard letter (k).  I pressed the button on the joystick and boom X crashed.

This is 100% reproducible on Live image at least on my laptop hardware.  I am happy to help with any debugging with some direction.

[  190.934828] usb 2-1: new low-speed USB device number 2 using xhci_hcd
[  191.169569] usb 2-1: New USB device found, idVendor=046d, idProduct=c219
[  191.169571] usb 2-1: New USB device strings: Mfr=3, Product=1, SerialNumber=0
[  191.169572] usb 2-1: Product: Logitech Cordless RumblePad 2
[  191.169573] usb 2-1: Manufacturer: Logitech
[  191.250581] input: Logitech Logitech Cordless RumblePad 2 as /devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.0/0003:046D:C219.0001/input/input18
[  191.251032] logitech 0003:046D:C219.0001: input,hidraw0: USB HID v1.10 Gamepad [Logitech Logitech Cordless RumblePad 2] on usb-0000:00:14.0-1/input0
[  191.251034] hid_logitech: Force feedback for Logitech force feedback devices by Johann Deneux <johann.deneux@it.uu.se>


[matt.lewis@snoopy ~]$ lspci 
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation Broadwell-U Processor Thermal Subsystem (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (3) I218-LM (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
00:1c.4 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #5 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
01:00.0 SD Host controller: O2 Micro, Inc. SD/MMC Card Reader Controller (rev 01)
02:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)

Comment 4 penguinbait 2017-01-30 03:05:05 UTC
Following these instructions from https://fedoraproject.org/wiki/How_to_debug_Wayland_problems

Testing under different compositors
If you experience a problem with a Wayland app, it is very useful to know whether the problem is present under just a single compositor (in that case it's likely a compositor bug) or under multiple compositors (in that case it's likely an app/toolkit bug).

Please run your session with the reference Weston compositor and try to reproduce the issue. You can either run Weston as a nested window, or as a full session. First, install weston package (you can read many useful information in its man page):

$ sudo dnf install weston
Then create a config file which will specify that you want to have XWayland support enabled in your weston sessions. Create ~/.config/weston.ini with this contents:

[core]
modules=xwayland.so
Now you can start weston either as nested window or as a full session.

To start a nested Weston window, run this from a terminal:
$ weston
A Weston window should open and you should see and a terminal icon in its top left corner. Use that icon to launch a terminal and from that you can run apps and other commands using Weston. Exit the compositor by simply closing the window or killing the weston process.

To start a full Weston session (not nested inside another X11 or Wayland session), switch to a free VT (Ctrl+Alt+Fx) and run:
$ weston-launch
----------------------------------------------------------

Resulted in 

[matt.lewis@snoopy ~]$ antimicro 
The X11 connection broke (error 1). Did the X11 server die?
QObject::killTimer: Timers cannot be stopped from another thread
QObject::~QObject: Timers cannot be stopped from another thread
[matt.lewis@snoopy ~]$

Comment 5 penguinbait 2017-01-31 02:24:50 UTC
Created attachment 1246067 [details]
strace attach pid crash output

Comment 6 penguinbait 2017-01-31 02:29:31 UTC
Created attachment 1246068 [details]
Example strace attached to antimicro pid - capture crash

Comment 7 penguinbait 2017-01-31 02:30:28 UTC
Created attachment 1246069 [details]
Example strace attached to Xwayland pid - capture crash

Comment 8 penguinbait 2017-01-31 02:47:10 UTC
Found work around, by disabling Xwayland

edit /etc/gdm/custom.conf and un-comment line below

#WaylandEnable=false

----------
init 3 
init 5

login and now I can use my joystick with antimicro

I will be running Xorg for now, if anyone needs anything I am happy to switch back and test.  I provided everything I can think of, happy to provide more.

Thanks,

Comment 9 Olivier Fourdan 2017-02-27 13:40:02 UTC
yeap, reproduced.

Comment 10 Olivier Fourdan 2017-02-27 14:20:48 UTC
Possible fix here:

https://patchwork.freedesktop.org/series/20315/

Comment 11 penguinbait 2017-03-07 02:07:36 UTC
I installed these packages this morning and I am now experiencing the exact same behavior using Xwayland.

However I am confused.  GDM is still disabling Xwayland, but WAYLAND_DISPLAY is set, but Xorg is running?

I have no idea what is happening? lol


[matt.lewis@snoopy ~]$ cat /etc/gdm/custom.conf
# GDM configuration storage

[daemon]
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true



[matt.lewis@snoopy ~]$ echo $WAYLAND_DISPLAY 
wayland-0


[matt.lewis@snoopy ~]$ ps -fe | grep Xorg
gdm       1615  1612  0 19:26 tty1     00:00:00 /usr/libexec/Xorg vt1 -displayfd 3 -auth /run/user/42/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3


libblockdev-utils-1.9-10.fc25.x86_64          Mon 06 Mar 2017 07:00:38 AM EST
nss-util-3.28.3-1.0.fc25.x86_64               Mon 06 Mar 2017 07:00:38 AM EST
libblockdev-1.9-10.fc25.x86_64                Mon 06 Mar 2017 07:00:39 AM EST
libsss_idmap-1.15.0-1.fc25.x86_64             Mon 06 Mar 2017 07:00:39 AM EST
pango-1.40.4-1.fc25.x86_64                    Mon 06 Mar 2017 07:00:39 AM EST
libblockdev-btrfs-1.9-10.fc25.x86_64          Mon 06 Mar 2017 07:00:41 AM EST
libbsd-0.8.3-1.fc25.x86_64                    Mon 06 Mar 2017 07:00:41 AM EST
libICE-1.0.9-8.fc25.x86_64                    Mon 06 Mar 2017 07:00:41 AM EST
libpinyin-1.9.91-2.fc25.x86_64                Mon 06 Mar 2017 07:00:41 AM EST
libpinyin-data-1.9.91-2.fc25.x86_64           Mon 06 Mar 2017 07:00:41 AM EST
libXdmcp-1.1.2-5.fc25.x86_64                  Mon 06 Mar 2017 07:00:41 AM EST
pango-devel-1.40.4-1.fc25.x86_64              Mon 06 Mar 2017 07:00:41 AM EST
libblockdev-dm-1.9-10.fc25.x86_64             Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-fs-1.9-10.fc25.x86_64             Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-kbd-1.9-10.fc25.x86_64            Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-loop-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-lvm-1.9-10.fc25.x86_64            Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-mdraid-1.9-10.fc25.x86_64         Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-mpath-1.9-10.fc25.x86_64          Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-part-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-swap-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:00:42 AM EST
kde-apps-rpm-macros-4.14.29-2.fc25.noarch     Mon 06 Mar 2017 07:00:43 AM EST
kdelibs-common-4.14.29-2.fc25.x86_64          Mon 06 Mar 2017 07:00:43 AM EST
kdelibs-ktexteditor-4.14.29-2.fc25.x86_64     Mon 06 Mar 2017 07:00:43 AM EST
kdelibs-webkit-4.14.29-2.fc25.x86_64          Mon 06 Mar 2017 07:00:43 AM EST
libipa_hbac-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:00:43 AM EST
libsss_nss_idmap-1.15.0-1.fc25.x86_64         Mon 06 Mar 2017 07:00:43 AM EST
libwacom-data-0.24-1.fc25.noarch              Mon 06 Mar 2017 07:00:43 AM EST
python3-sssdconfig-1.15.0-1.fc25.noarch       Mon 06 Mar 2017 07:00:43 AM EST
sssd-client-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:00:43 AM EST
gtk-update-icon-cache-3.22.9-2.fc25.x86_64    Mon 06 Mar 2017 07:00:46 AM EST
kdelibs-4.14.29-2.fc25.x86_64                 Mon 06 Mar 2017 07:00:46 AM EST
nss-softokn-3.28.3-1.1.fc25.x86_64            Mon 06 Mar 2017 07:00:46 AM EST
nss-softokn-freebl-3.28.3-1.1.fc25.x86_64     Mon 06 Mar 2017 07:00:46 AM EST
gtk3-3.22.9-2.fc25.x86_64                     Mon 06 Mar 2017 07:00:47 AM EST
coreutils-common-8.25-16.fc25.x86_64          Mon 06 Mar 2017 07:00:48 AM EST
totem-3.22.1-1.fc25.x86_64                    Mon 06 Mar 2017 07:00:48 AM EST
coreutils-8.25-16.fc25.x86_64                 Mon 06 Mar 2017 07:00:49 AM EST
kernel-core-4.9.13-200.fc25.x86_64            Mon 06 Mar 2017 07:00:51 AM EST
kernel-modules-4.9.13-200.fc25.x86_64         Mon 06 Mar 2017 07:00:53 AM EST
nss-3.28.3-1.0.fc25.x86_64                    Mon 06 Mar 2017 07:00:57 AM EST
nss-sysinit-3.28.3-1.0.fc25.x86_64            Mon 06 Mar 2017 07:00:57 AM EST
sssd-common-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:00:57 AM EST
sssd-common-pac-1.15.0-1.fc25.x86_64          Mon 06 Mar 2017 07:00:57 AM EST
sssd-krb5-common-1.15.0-1.fc25.x86_64         Mon 06 Mar 2017 07:00:57 AM EST
sssd-ad-1.15.0-1.fc25.x86_64                  Mon 06 Mar 2017 07:00:58 AM EST
sssd-ipa-1.15.0-1.fc25.x86_64                 Mon 06 Mar 2017 07:00:58 AM EST
sssd-krb5-1.15.0-1.fc25.x86_64                Mon 06 Mar 2017 07:00:58 AM EST
sssd-ldap-1.15.0-1.fc25.x86_64                Mon 06 Mar 2017 07:00:58 AM EST
bind99-libs-9.9.9-4.P6.fc25.x86_64            Mon 06 Mar 2017 07:01:03 AM EST
bind99-license-9.9.9-4.P6.fc25.noarch         Mon 06 Mar 2017 07:01:03 AM EST
java-1.8.0-openjdk-headless-1.8.0.121-8.b14.fc25.x86_64 Mon 06 Mar 2017 07:01:03 AM EST
libblockdev-crypto-1.9-10.fc25.x86_64         Mon 06 Mar 2017 07:01:03 AM EST
open-vm-tools-10.1.5-2.fc25.x86_64            Mon 06 Mar 2017 07:01:03 AM EST
java-1.8.0-openjdk-1.8.0.121-8.b14.fc25.x86_64 Mon 06 Mar 2017 07:01:04 AM EST
kernel-4.9.13-200.fc25.x86_64                 Mon 06 Mar 2017 07:01:04 AM EST
kernel-modules-extra-4.9.13-200.fc25.x86_64   Mon 06 Mar 2017 07:01:04 AM EST
libblockdev-plugins-all-1.9-10.fc25.x86_64    Mon 06 Mar 2017 07:01:04 AM EST
libcacard-2.5.3-1.fc25.x86_64                 Mon 06 Mar 2017 07:01:04 AM EST
nss-tools-3.28.3-1.0.fc25.x86_64              Mon 06 Mar 2017 07:01:04 AM EST
open-vm-tools-desktop-10.1.5-2.fc25.x86_64    Mon 06 Mar 2017 07:01:04 AM EST
sssd-1.15.0-1.fc25.x86_64                     Mon 06 Mar 2017 07:01:04 AM EST
sssd-proxy-1.15.0-1.fc25.x86_64               Mon 06 Mar 2017 07:01:04 AM EST
file-roller-3.22.3-1.fc25.x86_64              Mon 06 Mar 2017 07:01:09 AM EST
gdm-3.22.2-1.fc25.x86_64                      Mon 06 Mar 2017 07:01:09 AM EST
totem-nautilus-3.22.1-1.fc25.x86_64           Mon 06 Mar 2017 07:01:09 AM EST
gnome-calendar-3.22.3-1.fc25.x86_64           Mon 06 Mar 2017 07:01:10 AM EST
gtk3-devel-3.22.9-2.fc25.x86_64               Mon 06 Mar 2017 07:01:11 AM EST
ibus-libpinyin-1.8.91-2.fc25.x86_64           Mon 06 Mar 2017 07:01:11 AM EST
libICE-devel-1.0.9-8.fc25.x86_64              Mon 06 Mar 2017 07:01:11 AM EST
libwacom-0.24-1.fc25.x86_64                   Mon 06 Mar 2017 07:01:11 AM EST
python3-blockdev-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:01:12 AM EST
vala-0.34.5-1.fc25.x86_64                     Mon 06 Mar 2017 07:01:12 AM EST
libcmis-0.5.1-5.fc25.x86_64                   Mon 06 Mar 2017 07:01:13 AM EST
libseccomp-2.3.2-1.fc25.x86_64                Mon 06 Mar 2017 07:01:13 AM EST
libsss_autofs-1.15.0-1.fc25.x86_64            Mon 06 Mar 2017 07:01:13 AM EST
libsss_sudo-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:01:13 AM EST
mtr-0.87-2.fc25.x86_64                        Mon 06 Mar 2017 07:01:13 AM EST
sssd-nfs-idmap-1.15.0-1.fc25.x86_64           Mon 06 Mar 2017 07:01:13 AM EST
terminator-1.91-2.fc25.noarch                 Mon 06 Mar 2017 07:01:13 AM EST
iw-4.9-1.fc25.x86_64                          Mon 06 Mar 2017 07:01:14 AM EST
kernel-headers-4.9.13-200.fc25.x86_64         Mon 06 Mar 2017 07:01:14 AM EST
chrome-gnome-shell-8.2-1.fc25.noarch          Mon 06 Mar 2017 07:01:15 AM EST
cifs-utils-6.7-1.fc25.x86_64                  Mon 06 Mar 2017 07:01:15 AM EST
gssproxy-0.6.2-2.fc25.x86_64                  Mon 06 Mar 2017 07:01:15 AM EST
gstreamer1-libav-1.10.4-1.fc25.x86_64         Mon 06 Mar 2017 07:01:15 AM EST
gstreamer1-plugins-bad-freeworld-1.10.4-1.fc25.x86_64 Mon 06 Mar 2017 07:01:15 AM EST
gstreamer1-plugins-ugly-1.10.4-1.fc25.x86_64  Mon 06 Mar 2017 07:01:15 AM EST
ibus-typing-booster-1.5.23-1.fc25.noarch      Mon 06 Mar 2017 07:01:15 AM EST
python2-idna-2.4-1.fc25.noarch                Mon 06 Mar 2017 07:01:15 AM EST
kernel-devel-4.9.13-200.fc25.x86_64           Mon 06 Mar 2017 07:01:29 AM EST
nss-3.28.3-1.0.fc25.i686                      Mon 06 Mar 2017 07:01:45 AM EST
nss-softokn-3.28.3-1.1.fc25.i686              Mon 06 Mar 2017 07:01:45 AM EST
nss-softokn-freebl-3.28.3-1.1.fc25.i686       Mon 06 Mar 2017 07:01:45 AM EST
nss-util-3.28.3-1.0.fc25.i686                 Mon 06 Mar 2017 07:01:45 AM EST
java-1.8.0-openjdk-headless-1.8.0.121-8.b14.fc25.i686 Mon 06 Mar 2017 07:01:50 AM EST
libbsd-0.8.3-1.fc25.i686                      Mon 06 Mar 2017 07:01:50 AM EST
libICE-1.0.9-8.fc25.i686                      Mon 06 Mar 2017 07:01:50 AM EST
java-1.8.0-openjdk-1.8.0.121-8.b14.fc25.i686  Mon 06 Mar 2017 07:01:51 AM EST
libseccomp-2.3.2-1.fc25.i686                  Mon 06 Mar 2017 07:01:51 AM EST
pango-1.40.4-1.fc25.i686                      Mon 06 Mar 2017 07:01:51 AM EST
libblockdev-utils-1.9-10.fc25.x86_64          Mon 06 Mar 2017 07:00:38 AM EST
nss-util-3.28.3-1.0.fc25.x86_64               Mon 06 Mar 2017 07:00:38 AM EST
libblockdev-1.9-10.fc25.x86_64                Mon 06 Mar 2017 07:00:39 AM EST
libsss_idmap-1.15.0-1.fc25.x86_64             Mon 06 Mar 2017 07:00:39 AM EST
pango-1.40.4-1.fc25.x86_64                    Mon 06 Mar 2017 07:00:39 AM EST
libblockdev-btrfs-1.9-10.fc25.x86_64          Mon 06 Mar 2017 07:00:41 AM EST
libbsd-0.8.3-1.fc25.x86_64                    Mon 06 Mar 2017 07:00:41 AM EST
libICE-1.0.9-8.fc25.x86_64                    Mon 06 Mar 2017 07:00:41 AM EST
libpinyin-1.9.91-2.fc25.x86_64                Mon 06 Mar 2017 07:00:41 AM EST
libpinyin-data-1.9.91-2.fc25.x86_64           Mon 06 Mar 2017 07:00:41 AM EST
libXdmcp-1.1.2-5.fc25.x86_64                  Mon 06 Mar 2017 07:00:41 AM EST
pango-devel-1.40.4-1.fc25.x86_64              Mon 06 Mar 2017 07:00:41 AM EST
libblockdev-dm-1.9-10.fc25.x86_64             Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-fs-1.9-10.fc25.x86_64             Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-kbd-1.9-10.fc25.x86_64            Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-loop-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-lvm-1.9-10.fc25.x86_64            Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-mdraid-1.9-10.fc25.x86_64         Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-mpath-1.9-10.fc25.x86_64          Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-part-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-swap-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:00:42 AM EST
kde-apps-rpm-macros-4.14.29-2.fc25.noarch     Mon 06 Mar 2017 07:00:43 AM EST
kdelibs-common-4.14.29-2.fc25.x86_64          Mon 06 Mar 2017 07:00:43 AM EST
kdelibs-ktexteditor-4.14.29-2.fc25.x86_64     Mon 06 Mar 2017 07:00:43 AM EST
kdelibs-webkit-4.14.29-2.fc25.x86_64          Mon 06 Mar 2017 07:00:43 AM EST
libipa_hbac-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:00:43 AM EST
libsss_nss_idmap-1.15.0-1.fc25.x86_64         Mon 06 Mar 2017 07:00:43 AM EST
libwacom-data-0.24-1.fc25.noarch              Mon 06 Mar 2017 07:00:43 AM EST
python3-sssdconfig-1.15.0-1.fc25.noarch       Mon 06 Mar 2017 07:00:43 AM EST
sssd-client-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:00:43 AM EST
gtk-update-icon-cache-3.22.9-2.fc25.x86_64    Mon 06 Mar 2017 07:00:46 AM EST
kdelibs-4.14.29-2.fc25.x86_64                 Mon 06 Mar 2017 07:00:46 AM EST
nss-softokn-3.28.3-1.1.fc25.x86_64            Mon 06 Mar 2017 07:00:46 AM EST
nss-softokn-freebl-3.28.3-1.1.fc25.x86_64     Mon 06 Mar 2017 07:00:46 AM EST
gtk3-3.22.9-2.fc25.x86_64                     Mon 06 Mar 2017 07:00:47 AM EST
coreutils-common-8.25-16.fc25.x86_64          Mon 06 Mar 2017 07:00:48 AM EST
totem-3.22.1-1.fc25.x86_64                    Mon 06 Mar 2017 07:00:48 AM EST
coreutils-8.25-16.fc25.x86_64                 Mon 06 Mar 2017 07:00:49 AM EST
kernel-core-4.9.13-200.fc25.x86_64            Mon 06 Mar 2017 07:00:51 AM EST
kernel-modules-4.9.13-200.fc25.x86_64         Mon 06 Mar 2017 07:00:53 AM EST
nss-3.28.3-1.0.fc25.x86_64                    Mon 06 Mar 2017 07:00:57 AM EST
nss-sysinit-3.28.3-1.0.fc25.x86_64            Mon 06 Mar 2017 07:00:57 AM EST
sssd-common-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:00:57 AM EST
sssd-common-pac-1.15.0-1.fc25.x86_64          Mon 06 Mar 2017 07:00:57 AM EST
sssd-krb5-common-1.15.0-1.fc25.x86_64         Mon 06 Mar 2017 07:00:57 AM EST
sssd-ad-1.15.0-1.fc25.x86_64                  Mon 06 Mar 2017 07:00:58 AM EST
sssd-ipa-1.15.0-1.fc25.x86_64                 Mon 06 Mar 2017 07:00:58 AM EST
sssd-krb5-1.15.0-1.fc25.x86_64                Mon 06 Mar 2017 07:00:58 AM EST
sssd-ldap-1.15.0-1.fc25.x86_64                Mon 06 Mar 2017 07:00:58 AM EST
bind99-libs-9.9.9-4.P6.fc25.x86_64            Mon 06 Mar 2017 07:01:03 AM EST
bind99-license-9.9.9-4.P6.fc25.noarch         Mon 06 Mar 2017 07:01:03 AM EST
java-1.8.0-openjdk-headless-1.8.0.121-8.b14.fc25.x86_64 Mon 06 Mar 2017 07:01:03 AM EST
libblockdev-crypto-1.9-10.fc25.x86_64         Mon 06 Mar 2017 07:01:03 AM EST
open-vm-tools-10.1.5-2.fc25.x86_64            Mon 06 Mar 2017 07:01:03 AM EST
java-1.8.0-openjdk-1.8.0.121-8.b14.fc25.x86_64 Mon 06 Mar 2017 07:01:04 AM EST
kernel-4.9.13-200.fc25.x86_64                 Mon 06 Mar 2017 07:01:04 AM EST
kernel-modules-extra-4.9.13-200.fc25.x86_64   Mon 06 Mar 2017 07:01:04 AM EST
libblockdev-plugins-all-1.9-10.fc25.x86_64    Mon 06 Mar 2017 07:01:04 AM EST
libcacard-2.5.3-1.fc25.x86_64                 Mon 06 Mar 2017 07:01:04 AM EST
nss-tools-3.28.3-1.0.fc25.x86_64              Mon 06 Mar 2017 07:01:04 AM EST
open-vm-tools-desktop-10.1.5-2.fc25.x86_64    Mon 06 Mar 2017 07:01:04 AM EST
sssd-1.15.0-1.fc25.x86_64                     Mon 06 Mar 2017 07:01:04 AM EST
sssd-proxy-1.15.0-1.fc25.x86_64               Mon 06 Mar 2017 07:01:04 AM EST
file-roller-3.22.3-1.fc25.x86_64              Mon 06 Mar 2017 07:01:09 AM EST
gdm-3.22.2-1.fc25.x86_64                      Mon 06 Mar 2017 07:01:09 AM EST
totem-nautilus-3.22.1-1.fc25.x86_64           Mon 06 Mar 2017 07:01:09 AM EST
gnome-calendar-3.22.3-1.fc25.x86_64           Mon 06 Mar 2017 07:01:10 AM EST
gtk3-devel-3.22.9-2.fc25.x86_64               Mon 06 Mar 2017 07:01:11 AM EST
ibus-libpinyin-1.8.91-2.fc25.x86_64           Mon 06 Mar 2017 07:01:11 AM EST
libICE-devel-1.0.9-8.fc25.x86_64              Mon 06 Mar 2017 07:01:11 AM EST
libwacom-0.24-1.fc25.x86_64                   Mon 06 Mar 2017 07:01:11 AM EST
python3-blockdev-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:01:12 AM EST
vala-0.34.5-1.fc25.x86_64                     Mon 06 Mar 2017 07:01:12 AM EST
libcmis-0.5.1-5.fc25.x86_64                   Mon 06 Mar 2017 07:01:13 AM EST
libseccomp-2.3.2-1.fc25.x86_64                Mon 06 Mar 2017 07:01:13 AM EST
libsss_autofs-1.15.0-1.fc25.x86_64            Mon 06 Mar 2017 07:01:13 AM EST
libsss_sudo-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:01:13 AM EST
mtr-0.87-2.fc25.x86_64                        Mon 06 Mar 2017 07:01:13 AM EST
sssd-nfs-idmap-1.15.0-1.fc25.x86_64           Mon 06 Mar 2017 07:01:13 AM EST
terminator-1.91-2.fc25.noarch                 Mon 06 Mar 2017 07:01:13 AM EST
iw-4.9-1.fc25.x86_64                          Mon 06 Mar 2017 07:01:14 AM EST
kernel-headers-4.9.13-200.fc25.x86_64         Mon 06 Mar 2017 07:01:14 AM EST
chrome-gnome-shell-8.2-1.fc25.noarch          Mon 06 Mar 2017 07:01:15 AM EST
cifs-utils-6.7-1.fc25.x86_64                  Mon 06 Mar 2017 07:01:15 AM EST
gssproxy-0.6.2-2.fc25.x86_64                  Mon 06 Mar 2017 07:01:15 AM EST
gstreamer1-libav-1.10.4-1.fc25.x86_64         Mon 06 Mar 2017 07:01:15 AM EST
gstreamer1-plugins-bad-freeworld-1.10.4-1.fc25.x86_64 Mon 06 Mar 2017 07:01:15 AM EST
gstreamer1-plugins-ugly-1.10.4-1.fc25.x86_64  Mon 06 Mar 2017 07:01:15 AM EST
ibus-typing-booster-1.5.23-1.fc25.noarch      Mon 06 Mar 2017 07:01:15 AM EST
python2-idna-2.4-1.fc25.noarch                Mon 06 Mar 2017 07:01:15 AM EST
kernel-devel-4.9.13-200.fc25.x86_64           Mon 06 Mar 2017 07:01:29 AM EST
nss-3.28.3-1.0.fc25.i686                      Mon 06 Mar 2017 07:01:45 AM EST
nss-softokn-3.28.3-1.1.fc25.i686              Mon 06 Mar 2017 07:01:45 AM EST
nss-softokn-freebl-3.28.3-1.1.fc25.i686       Mon 06 Mar 2017 07:01:45 AM EST
nss-util-3.28.3-1.0.fc25.i686                 Mon 06 Mar 2017 07:01:45 AM EST
java-1.8.0-openjdk-headless-1.8.0.121-8.b14.fc25.i686 Mon 06 Mar 2017 07:01:50 AM EST
libbsd-0.8.3-1.fc25.i686                      Mon 06 Mar 2017 07:01:50 AM EST
libICE-1.0.9-8.fc25.i686                      Mon 06 Mar 2017 07:01:50 AM EST
java-1.8.0-openjdk-1.8.0.121-8.b14.fc25.i686  Mon 06 Mar 2017 07:01:51 AM EST
libseccomp-2.3.2-1.fc25.i686                  Mon 06 Mar 2017 07:01:51 AM EST
pango-1.40.4-1.fc25.i686                      Mon 06 Mar 2017 07:01:51 AM EST

Comment 12 penguinbait 2017-03-07 02:09:25 UTC
Sorry, got a double paste of packages updated today.

libblockdev-utils-1.9-10.fc25.x86_64          Mon 06 Mar 2017 07:00:38 AM EST
nss-util-3.28.3-1.0.fc25.x86_64               Mon 06 Mar 2017 07:00:38 AM EST
libblockdev-1.9-10.fc25.x86_64                Mon 06 Mar 2017 07:00:39 AM EST
libsss_idmap-1.15.0-1.fc25.x86_64             Mon 06 Mar 2017 07:00:39 AM EST
pango-1.40.4-1.fc25.x86_64                    Mon 06 Mar 2017 07:00:39 AM EST
libblockdev-btrfs-1.9-10.fc25.x86_64          Mon 06 Mar 2017 07:00:41 AM EST
libbsd-0.8.3-1.fc25.x86_64                    Mon 06 Mar 2017 07:00:41 AM EST
libICE-1.0.9-8.fc25.x86_64                    Mon 06 Mar 2017 07:00:41 AM EST
libpinyin-1.9.91-2.fc25.x86_64                Mon 06 Mar 2017 07:00:41 AM EST
libpinyin-data-1.9.91-2.fc25.x86_64           Mon 06 Mar 2017 07:00:41 AM EST
libXdmcp-1.1.2-5.fc25.x86_64                  Mon 06 Mar 2017 07:00:41 AM EST
pango-devel-1.40.4-1.fc25.x86_64              Mon 06 Mar 2017 07:00:41 AM EST
libblockdev-dm-1.9-10.fc25.x86_64             Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-fs-1.9-10.fc25.x86_64             Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-kbd-1.9-10.fc25.x86_64            Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-loop-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-lvm-1.9-10.fc25.x86_64            Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-mdraid-1.9-10.fc25.x86_64         Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-mpath-1.9-10.fc25.x86_64          Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-part-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:00:42 AM EST
libblockdev-swap-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:00:42 AM EST
kde-apps-rpm-macros-4.14.29-2.fc25.noarch     Mon 06 Mar 2017 07:00:43 AM EST
kdelibs-common-4.14.29-2.fc25.x86_64          Mon 06 Mar 2017 07:00:43 AM EST
kdelibs-ktexteditor-4.14.29-2.fc25.x86_64     Mon 06 Mar 2017 07:00:43 AM EST
kdelibs-webkit-4.14.29-2.fc25.x86_64          Mon 06 Mar 2017 07:00:43 AM EST
libipa_hbac-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:00:43 AM EST
libsss_nss_idmap-1.15.0-1.fc25.x86_64         Mon 06 Mar 2017 07:00:43 AM EST
libwacom-data-0.24-1.fc25.noarch              Mon 06 Mar 2017 07:00:43 AM EST
python3-sssdconfig-1.15.0-1.fc25.noarch       Mon 06 Mar 2017 07:00:43 AM EST
sssd-client-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:00:43 AM EST
gtk-update-icon-cache-3.22.9-2.fc25.x86_64    Mon 06 Mar 2017 07:00:46 AM EST
kdelibs-4.14.29-2.fc25.x86_64                 Mon 06 Mar 2017 07:00:46 AM EST
nss-softokn-3.28.3-1.1.fc25.x86_64            Mon 06 Mar 2017 07:00:46 AM EST
nss-softokn-freebl-3.28.3-1.1.fc25.x86_64     Mon 06 Mar 2017 07:00:46 AM EST
gtk3-3.22.9-2.fc25.x86_64                     Mon 06 Mar 2017 07:00:47 AM EST
coreutils-common-8.25-16.fc25.x86_64          Mon 06 Mar 2017 07:00:48 AM EST
totem-3.22.1-1.fc25.x86_64                    Mon 06 Mar 2017 07:00:48 AM EST
coreutils-8.25-16.fc25.x86_64                 Mon 06 Mar 2017 07:00:49 AM EST
kernel-core-4.9.13-200.fc25.x86_64            Mon 06 Mar 2017 07:00:51 AM EST
kernel-modules-4.9.13-200.fc25.x86_64         Mon 06 Mar 2017 07:00:53 AM EST
nss-3.28.3-1.0.fc25.x86_64                    Mon 06 Mar 2017 07:00:57 AM EST
nss-sysinit-3.28.3-1.0.fc25.x86_64            Mon 06 Mar 2017 07:00:57 AM EST
sssd-common-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:00:57 AM EST
sssd-common-pac-1.15.0-1.fc25.x86_64          Mon 06 Mar 2017 07:00:57 AM EST
sssd-krb5-common-1.15.0-1.fc25.x86_64         Mon 06 Mar 2017 07:00:57 AM EST
sssd-ad-1.15.0-1.fc25.x86_64                  Mon 06 Mar 2017 07:00:58 AM EST
sssd-ipa-1.15.0-1.fc25.x86_64                 Mon 06 Mar 2017 07:00:58 AM EST
sssd-krb5-1.15.0-1.fc25.x86_64                Mon 06 Mar 2017 07:00:58 AM EST
sssd-ldap-1.15.0-1.fc25.x86_64                Mon 06 Mar 2017 07:00:58 AM EST
bind99-libs-9.9.9-4.P6.fc25.x86_64            Mon 06 Mar 2017 07:01:03 AM EST
bind99-license-9.9.9-4.P6.fc25.noarch         Mon 06 Mar 2017 07:01:03 AM EST
java-1.8.0-openjdk-headless-1.8.0.121-8.b14.fc25.x86_64 Mon 06 Mar 2017 07:01:03 AM EST
libblockdev-crypto-1.9-10.fc25.x86_64         Mon 06 Mar 2017 07:01:03 AM EST
open-vm-tools-10.1.5-2.fc25.x86_64            Mon 06 Mar 2017 07:01:03 AM EST
java-1.8.0-openjdk-1.8.0.121-8.b14.fc25.x86_64 Mon 06 Mar 2017 07:01:04 AM EST
kernel-4.9.13-200.fc25.x86_64                 Mon 06 Mar 2017 07:01:04 AM EST
kernel-modules-extra-4.9.13-200.fc25.x86_64   Mon 06 Mar 2017 07:01:04 AM EST
libblockdev-plugins-all-1.9-10.fc25.x86_64    Mon 06 Mar 2017 07:01:04 AM EST
libcacard-2.5.3-1.fc25.x86_64                 Mon 06 Mar 2017 07:01:04 AM EST
nss-tools-3.28.3-1.0.fc25.x86_64              Mon 06 Mar 2017 07:01:04 AM EST
open-vm-tools-desktop-10.1.5-2.fc25.x86_64    Mon 06 Mar 2017 07:01:04 AM EST
sssd-1.15.0-1.fc25.x86_64                     Mon 06 Mar 2017 07:01:04 AM EST
sssd-proxy-1.15.0-1.fc25.x86_64               Mon 06 Mar 2017 07:01:04 AM EST
file-roller-3.22.3-1.fc25.x86_64              Mon 06 Mar 2017 07:01:09 AM EST
gdm-3.22.2-1.fc25.x86_64                      Mon 06 Mar 2017 07:01:09 AM EST
totem-nautilus-3.22.1-1.fc25.x86_64           Mon 06 Mar 2017 07:01:09 AM EST
gnome-calendar-3.22.3-1.fc25.x86_64           Mon 06 Mar 2017 07:01:10 AM EST
gtk3-devel-3.22.9-2.fc25.x86_64               Mon 06 Mar 2017 07:01:11 AM EST
ibus-libpinyin-1.8.91-2.fc25.x86_64           Mon 06 Mar 2017 07:01:11 AM EST
libICE-devel-1.0.9-8.fc25.x86_64              Mon 06 Mar 2017 07:01:11 AM EST
libwacom-0.24-1.fc25.x86_64                   Mon 06 Mar 2017 07:01:11 AM EST
python3-blockdev-1.9-10.fc25.x86_64           Mon 06 Mar 2017 07:01:12 AM EST
vala-0.34.5-1.fc25.x86_64                     Mon 06 Mar 2017 07:01:12 AM EST
libcmis-0.5.1-5.fc25.x86_64                   Mon 06 Mar 2017 07:01:13 AM EST
libseccomp-2.3.2-1.fc25.x86_64                Mon 06 Mar 2017 07:01:13 AM EST
libsss_autofs-1.15.0-1.fc25.x86_64            Mon 06 Mar 2017 07:01:13 AM EST
libsss_sudo-1.15.0-1.fc25.x86_64              Mon 06 Mar 2017 07:01:13 AM EST
mtr-0.87-2.fc25.x86_64                        Mon 06 Mar 2017 07:01:13 AM EST
sssd-nfs-idmap-1.15.0-1.fc25.x86_64           Mon 06 Mar 2017 07:01:13 AM EST
terminator-1.91-2.fc25.noarch                 Mon 06 Mar 2017 07:01:13 AM EST
iw-4.9-1.fc25.x86_64                          Mon 06 Mar 2017 07:01:14 AM EST
kernel-headers-4.9.13-200.fc25.x86_64         Mon 06 Mar 2017 07:01:14 AM EST
chrome-gnome-shell-8.2-1.fc25.noarch          Mon 06 Mar 2017 07:01:15 AM EST
cifs-utils-6.7-1.fc25.x86_64                  Mon 06 Mar 2017 07:01:15 AM EST
gssproxy-0.6.2-2.fc25.x86_64                  Mon 06 Mar 2017 07:01:15 AM EST
gstreamer1-libav-1.10.4-1.fc25.x86_64         Mon 06 Mar 2017 07:01:15 AM EST
gstreamer1-plugins-bad-freeworld-1.10.4-1.fc25.x86_64 Mon 06 Mar 2017 07:01:15 AM EST
gstreamer1-plugins-ugly-1.10.4-1.fc25.x86_64  Mon 06 Mar 2017 07:01:15 AM EST
ibus-typing-booster-1.5.23-1.fc25.noarch      Mon 06 Mar 2017 07:01:15 AM EST
python2-idna-2.4-1.fc25.noarch                Mon 06 Mar 2017 07:01:15 AM EST
kernel-devel-4.9.13-200.fc25.x86_64           Mon 06 Mar 2017 07:01:29 AM EST
nss-3.28.3-1.0.fc25.i686                      Mon 06 Mar 2017 07:01:45 AM EST
nss-softokn-3.28.3-1.1.fc25.i686              Mon 06 Mar 2017 07:01:45 AM EST
nss-softokn-freebl-3.28.3-1.1.fc25.i686       Mon 06 Mar 2017 07:01:45 AM EST
nss-util-3.28.3-1.0.fc25.i686                 Mon 06 Mar 2017 07:01:45 AM EST
java-1.8.0-openjdk-headless-1.8.0.121-8.b14.fc25.i686 Mon 06 Mar 2017 07:01:50 AM EST
libbsd-0.8.3-1.fc25.i686                      Mon 06 Mar 2017 07:01:50 AM EST
libICE-1.0.9-8.fc25.i686                      Mon 06 Mar 2017 07:01:50 AM EST
java-1.8.0-openjdk-1.8.0.121-8.b14.fc25.i686  Mon 06 Mar 2017 07:01:51 AM EST
libseccomp-2.3.2-1.fc25.i686                  Mon 06 Mar 2017 07:01:51 AM EST
pango-1.40.4-1.fc25.i686                      Mon 06 Mar 2017 07:01:51 AM EST

Comment 13 Olivier Fourdan 2017-03-07 08:05:29 UTC
(In reply to penguinbait from comment #11)
> I installed these packages this morning and I am now experiencing the exact
> same behavior using Xwayland.

So, you mean, it works?
 
> However I am confused.  GDM is still disabling Xwayland, but WAYLAND_DISPLAY
> is set, but Xorg is running?
> 
> I have no idea what is happening? lol
> 
> [matt.lewis@snoopy ~]$ cat /etc/gdm/custom.conf
> # GDM configuration storage
> 
> [daemon]
> # Uncoment the line below to force the login screen to use Xorg
> WaylandEnable=false

There ^^^^ you have Wayland disabled in gdm config, that might explain why Wayland is not enabled?

Comment 14 Olivier Fourdan 2017-03-07 12:42:32 UTC
Note, AFAIK the fix (comment 10) has landed in git upstream but is not yet available in fedora packages.

Comment 15 penguinbait 2017-03-07 14:02:38 UTC
No, I still have wayland disabled in GDM.

But I now appear to be running wayland?  So its not working for me.  Because it seems like I am no longer running Xorg?  I am not sure why.   However the only workaround I have now is to switch to run level 3 and startx if I want to play a game.


[matt.lewis@snoopy ~]$ echo $WAYLAND_DISPLAY 
wayland-0


[matt.lewis@snoopy ~]$ ps -fe | grep Xorg
gdm       1615  1612  0 19:26 tty1     00:00:00 /usr/libexec/Xorg vt1 -displayfd 3 -auth /run/user/42/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3


I guess this appears to be another bug, where I have WaylandEnable=false, and while GDM is running Xord, but my session is running Xwayland.

Comment 16 Olivier Fourdan 2017-03-07 14:10:30 UTC
Sorry you lost me there... Long story short, you need a fix in Xwayland which is not yet packaged.

As to why you are using Wayland, are you sure you picked "GNOME on Xorg" in gdm as your session?

Comment 17 penguinbait 2017-03-07 14:47:50 UTC
All I did was set WaylandEnable=false in /etc/gdm/custom.conf

[matt.lewis@snoopy ~]$ cat /etc/gdm/custom.conf
# GDM configuration storage

[daemon]
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=false


This allowed me to run Xorg when it booted up.  After yesterdays updates its no longer honoring this setting and I am running Xorg in gdm, and Xwayland for my windowed session.

I understand this fix is not packaged yet, do you have any idea when this will make it into updates?

Should I open another bug report?  Would that be for gdm ?

Thanks

Comment 18 Fedora Update System 2017-03-30 15:28:54 UTC
xorg-x11-server-1.19.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-fae700469f

Comment 19 Fedora Update System 2017-03-31 03:23:01 UTC
xorg-x11-server-1.19.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-fae700469f

Comment 20 Fedora Update System 2017-04-01 00:25:35 UTC
xorg-x11-server-1.19.3-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.