Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416256 - Unable to download rpm file from product's redhat repositories
Summary: Unable to download rpm file from product's redhat repositories
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Repositories
Version: 6.2.4
Hardware: All
OS: All
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 04:41 UTC by Ranjan Kumar
Modified: 2021-06-10 11:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 18:03:24 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ranjan Kumar 2017-01-25 04:41:34 UTC
Description of problem:
when I try and browse a redhat repositories and click on an RPM I get:

HTTP 404: Not found.
The URL you requested was not found on this server.

Version-Release number of selected component (if applicable): 6.2.4 satellite

How reproducible: 100%

Steps to Reproduce:
1. generated a debug certificate and import to browser
2. Go to Products -> "Red Hat Enterprise Linux Server" -> click any repository
3. click on "Published At". You will get a page of "Pulp Repository Content"
4. Now click on any link getting error HTTP 404: Not found.

Actual results: HTTP 404: Not found.


Expected results: Should allow to download rpm file


Additional info:
 The path of rpm file in hyperlink is incorrect. Currently its 
 
 https://sat-6/pulp/repos/Redhat/Library/content/dist/rhel/server/7/7Server/x86_64/extras/cockpit-0.53-3.el7.x86_64.rpm
 
 But it should be

 https://dhcp6-10.gsslab.pnq.redhat.com/pulp/repos/Redhat/Library/content/dist/rhel/server/7/7Server/x86_64/extras/os/cockpit-0.53-3.el7.x86_64.rpm

Workaround: Add '/os' before rpm file name in the url

Comment 1 Steven Mercurio 2017-02-03 04:10:08 UTC
I had this same issue on 6.2.6.  It turns out that if I refresh the manifest and then try to browse repos again it works.  Question is why?  If there is an issue why is there no warning or notification to tell you of a manifest issue and what caused the manifest issue to begin with?

Comment 2 Ranjan Kumar 2017-02-06 05:01:20 UTC
I tried to refresh manifest but the issue is still present. I think rest two question should be answered by engineering team

Comment 4 Bryan Kearney 2018-09-04 18:03:24 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.