Bug 1416265 - neutron-ns-metadata-proxy are not deleted after network is deleted
Summary: neutron-ns-metadata-proxy are not deleted after network is deleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z2
: 10.0 (Newton)
Assignee: Daniel Alvarez Sanchez
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 05:26 UTC by Itzik Brown
Modified: 2017-02-23 16:35 UTC (History)
6 users (show)

Fixed In Version: openstack-neutron-9.1.1-8.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, when a network was deleted, all ports and subnets were deleted before it could be determined if a metadata proxy had been spawned. Consequently, a false negative proxy was not killed, causing the system to eventually run out of memory. With this update, the metadata proxy process is killed unconditionally when the network is deleted.
Clone Of:
Environment:
Last Closed: 2017-02-23 16:35:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1648095 None None None 2017-01-25 07:22:52 UTC
OpenStack gerrit 411566 None None None 2017-01-25 05:26:17 UTC
Red Hat Product Errata RHBA-2017:0314 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2017-02-23 21:33:22 UTC

Description Itzik Brown 2017-01-25 05:26:17 UTC
Description of problem:
When using the following in DHCP agent configuation:
force_metadata=True

When network is deleted neutron-ns-metadata-proxy is not deleted and after couple of networks are created and deleted and eventually the system is out of memory.

Version-Release number of selected component (if applicable):
openstack-neutron-9.1.1-2.el7ost.noarch
python-neutron-lbaas-9.1.0-2.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.Configure force_metadata=True in /etc/neutron/dhcp_agent.ini
2.Restart DHCP agent - systemctl restart neutron-dhcp-agent
3.Create a network
4.Delete the network
5.Verify the process is not killed
  On the controller run ps -ef |grep <network-id> |grep neutron-ns-metadata-proxy 


Actual results:


Expected results:


Additional info:

Comment 1 Nir Yechiel 2017-01-25 07:27:02 UTC
Raising priority is this affects our OpenDaylight+Neutron integration. Due to this bug we see 100% memory consumption on the overcloud nodes which make them unusable.

Comment 5 Itzik Brown 2017-02-15 12:12:01 UTC
Verified with:
openstack-neutron-9.2.0-2.el7ost.noarch

Comment 7 errata-xmlrpc 2017-02-23 16:35:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0314.html


Note You need to log in before you can comment on or make changes to this bug.