Bug 1416305 - [downstream clone - 4.0.7] [RFE] Optimize performance of host monitoring
Summary: [downstream clone - 4.0.7] [RFE] Optimize performance of host monitoring
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.0.7
: ---
Assignee: Ravi Nori
QA Contact: Eldad Marciano
URL:
Whiteboard:
Depends On: 1388536
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 08:42 UTC by rhev-integ
Modified: 2017-03-16 15:31 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1388536
Environment:
Last Closed: 2017-03-16 15:31:25 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0542 0 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0.7 2017-03-16 19:25:04 UTC
oVirt gerrit 65924 0 master MERGED engine: Optimize performance of host monitoring 2017-01-25 08:43:15 UTC
oVirt gerrit 67999 0 ovirt-engine-4.0 POST engine: Optimize performance of host monitoring 2017-01-25 08:43:15 UTC
oVirt gerrit 68001 0 ovirt-engine-4.0.6 POST engine: Optimize performance of host monitoring 2017-01-25 08:43:15 UTC
oVirt gerrit 68018 0 ovirt-engine-3.6 POST engine: Optimize performance of host monitoring 2017-01-25 08:43:15 UTC

Description rhev-integ 2017-01-25 08:42:45 UTC
+++ This bug is an upstream to downstream clone. The original bug is: +++
+++   bug 1388536 +++
======================================================================

Description of problem:

Currently host monitoring is updating database data inefficiently and we have seen it causes big db load for larger setups. So we need to clean up the code here and optimize database updates similarly as it has been done inside VM monitoring

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

(Originally by Martin Perina)

Comment 3 rhev-integ 2017-01-25 08:42:59 UTC
Adding CodeChange, for testing it is sufficient the basic sanity on db performance with host and VM statuses. With this interval to write to vds_dynamic was changed from few seconds to 1-2 per minute.

(Originally by Lukas Svaty)

Comment 4 rhev-integ 2017-01-25 08:43:05 UTC
4.0.6 has been the last oVirt 4.0 release, please re-target this bug.

(Originally by Sandro Bonazzola)

Comment 6 Eldad Marciano 2017-02-02 12:54:21 UTC
Yaniv, based on this comment 
https://bugzilla.redhat.com/show_bug.cgi?id=1402859#c11
we can close it as well

Comment 7 Yaniv Kaul 2017-02-02 12:57:36 UTC
CodeChange - moving to VERIFIED.

Comment 9 errata-xmlrpc 2017-03-16 15:31:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0542.html


Note You need to log in before you can comment on or make changes to this bug.