Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416322 - register hypervisor name to satellite again will result in failed to show host/guest mapping info in webUI
Summary: register hypervisor name to satellite again will result in failed to show hos...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts - Content
Version: 6.2.7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 09:43 UTC by Liushihui
Modified: 2018-08-02 20:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-02 20:57:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
show_uuid.jpeg (167.80 KB, image/png)
2017-01-25 09:43 UTC, Liushihui
no flags Details
show_hostname.jpeg (197.94 KB, image/jpeg)
2017-01-25 09:45 UTC, Liushihui
no flags Details
show_uuid.jpeg (209.01 KB, image/jpeg)
2017-01-25 09:48 UTC, Liushihui
no flags Details

Description Liushihui 2017-01-25 09:43:08 UTC
Description of problem:
If the hypervisor has been registered to satellite, register it again will result in failed to associate host/guest mapping info.

Version-Release number of selected component (if applicable):
virt-who-0.17-10.el7sat.noarch
Satellite6.2.7-sp3

How reproducible:
Always

Steps to Reproduce:
1. Register guest to satellite6.2.7

******************The first time report hostname*******************
2. Configure virt-who report hypervisor's hostname to satellite
[root@bkr-hv03-guest20 virt-who.d]# cat /etc/virt-who.d/hyperv1 
[test-hyperv2]
type=hyperv
server=10.73.5.227
username=virtwho\administrator
encrypted_password=3ce98c643e783a83cc247b00ea3d2d3c
owner=org1
env=Library 
rhsm_username=admin
rhsm_encrypted_password=ce6d7d014da9d0a7f5590bdd15c376d2
rhsm_prefix=/rhsm
rhsm_port=443
rhsm_hostname=hp-ml370g6-01.rhts.eng.bos.redhat.com
hypervisor_id=hostname              ===============> Configure report hostname 

3. Start virt-who and check virt-who's log
[root@bkr-hv03-guest20 virt-who.d]# service virt-who restart && tail -f /var/log/rhsm/rhsm.log
2017-01-25 04:09:02,263 [virtwho.main DEBUG] MainProcess(1427):MainThread @subscriptionmanager.py:hypervisorCheckIn:195 - Host-to-guest mapping: {
    "virtwho_03": [      =======>Virt-who send hostname to satellite
        {
            "guestId": "5EF3A910-F00F-7447-A995-2BE57CA30A6F", 
            "state": 1, 
            "attributes": {
                "active": 1, 
                "virtWhoType": "hyperv"
            }
        }
    ]
}
2017-01-25 04:09:04,525 [virtwho.main DEBUG] MainProcess(1427):MainThread @executor.py:send_report:101 - Report for config "test-hyperv2" sent

4. In satellite webUI, go to Hosts--> Content host, it will show a new hypervisor "virt-who-virtwho-03-3"

5. In satellite webUI, go to Hosts--> Content host-->[Guest], click guest name , check guest's Virtual Host "virt-who-virtwho-03-3", see screenshot show_hostname.jpeg(It's correct)

******************The second time report hostuuid*******************
6. Modify virt-who's configure to report uuid instead of hostname as the following:
[root@bkr-hv03-guest20 virt-who.d]# cat /etc/virt-who.d/hyperv1 
[test-hyperv2]
type=hyperv
server=10.73.5.227
username=virtwho\administrator
encrypted_password=3ce98c643e783a83cc247b00ea3d2d3c
owner=org1
env=Library 
rhsm_username=admin
rhsm_encrypted_password=ce6d7d014da9d0a7f5590bdd15c376d2
rhsm_prefix=/rhsm
rhsm_port=443
rhsm_hostname=hp-ml370g6-01.rhts.eng.bos.redhat.com
hypervisor_id=uuid              ===============> Configure report uuid

7. Restart virt-who and check virt-who's log
[root@bkr-hv03-guest20 virt-who.d]# service virt-who restart && tail -f /var/log/rhsm/rhsm.log
2017-01-25 04:10:00,758 [virtwho.main DEBUG] MainProcess(1450):MainThread @subscriptionmanager.py:hypervisorCheckIn:195 - Host-to-guest mapping: {
    "564D84C1-0A16-E227-067D-472D286A9AC2": [  =======>Virt-who send uuid to satellite
        {
            "guestId": "5EF3A910-F00F-7447-A995-2BE57CA30A6F", 
            "state": 1, 
            "attributes": {
                "active": 1, 
                "virtWhoType": "hyperv"
            }
        }
    ]
}
2017-01-25 04:10:02,762 [virtwho.main DEBUG] MainProcess(1450):MainThread @executor.py:send_report:101 - Report for config "test-hyperv2" sent

8. In satellite webUI, go to Hosts--> Content host, it will show a new hypervisor "virt-who-564D84C1-0A16-E227-067D-472D286A9AC2-3"

9. In satellite webUI, go to Hosts--> Content host-->[Guest], click guest name , check guest's Virtual Host "virt-who-564D84C1-0A16-E227-067D-472D286A9AC2-3", see screenshot show_uuid.jpeg(It's correct)

******************The third time report hostname again*******************
10. Configure virt-who report hypervisor's hostname to satellite again.
[root@bkr-hv03-guest20 virt-who.d]# cat /etc/virt-who.d/hyperv1 
[test-hyperv2]
type=hyperv
server=10.73.5.227
username=virtwho\administrator
encrypted_password=3ce98c643e783a83cc247b00ea3d2d3c
owner=org1
env=Library 
rhsm_username=admin
rhsm_encrypted_password=ce6d7d014da9d0a7f5590bdd15c376d2
rhsm_prefix=/rhsm
rhsm_port=443
rhsm_hostname=hp-ml370g6-01.rhts.eng.bos.redhat.com
hypervisor_id=hostname              ===============> Configure report hostname 

11. Start virt-who and check virt-who's log
[root@bkr-hv03-guest20 virt-who.d]# service virt-who restart && tail -f /var/log/rhsm/rhsm.log
2017-01-25 04:10:40,008 [virtwho.main DEBUG] MainProcess(1471):MainThread @subscriptionmanager.py:hypervisorCheckIn:195 - Host-to-guest mapping: {
    "virtwho_03": [          =======>Virt-who send hostname to satellite
        {
            "guestId": "5EF3A910-F00F-7447-A995-2BE57CA30A6F", 
            "state": 1, 
            "attributes": {
                "active": 1, 
                "virtWhoType": "hyperv"
            }
        }
    ]
}
2017-01-25 04:10:40,711 [virtwho.main DEBUG] MainProcess(1471):MainThread @executor.py:send_report:101 - Report for config "test-hyperv2" sent

12. In satellite webUI, go to Hosts--> Content host-->[Guest], click guest name , check guest's Virtual Host 


Actual results:
Although virt-who send hypervisor's hostname to satellite, it still show guest's Virtual Host "virt-who-564D84C1-0A16-E227-067D-472D286A9AC2-3"

Expected results:
Since virt-who has updated the mapping info to satellite, it should update guest's Virtual Host to "virt-who-virtwho-03-3" in webUI.

Additional info:

Comment 1 Liushihui 2017-01-25 09:43:54 UTC
Created attachment 1244199 [details]
show_uuid.jpeg

Comment 2 Liushihui 2017-01-25 09:45:53 UTC
Created attachment 1244200 [details]
show_hostname.jpeg

Comment 3 Liushihui 2017-01-25 09:48:02 UTC
Created attachment 1244201 [details]
show_uuid.jpeg

Comment 5 Bryan Kearney 2018-08-02 20:57:38 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.