Bug 1416325 - firewall-cmd --set-description command fails
Summary: firewall-cmd --set-description command fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Thomas Woerner
QA Contact: Tomas Dolezal
URL:
Whiteboard:
: 1445238 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 09:48 UTC by Ole Holm Nielsen
Modified: 2020-09-10 10:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 16:22:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1445238 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Knowledge Base (Solution) 2992481 0 None None None 2017-04-05 13:30:27 UTC
Red Hat Product Errata RHBA-2017:1934 0 normal SHIPPED_LIVE firewalld bug fix and enhancement update 2017-08-01 17:55:15 UTC

Internal Links: 1445238

Description Ole Holm Nielsen 2017-01-25 09:48:22 UTC
Description of problem:
The firewall-cmd --set-description command fails with an error message.

Version-Release number of selected component (if applicable):
firewalld-0.4.3.2-8.1.el7_3.noarch

How reproducible: 
Always

Steps to Reproduce:
1. Add an ipset: firewall-cmd --permanent --new-ipset=geoblock --type=hash:net
2. Run firewall-cmd --permanent --ipset=geoblock --set-description="Geoblock ipset"

Actual results:
Error: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/firewall/client.py", line 53, in handle_exceptions
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/firewall/client.py", line 441, in update
    self.fw_zone.update(tuple(settings.settings))
AttributeError: 'FirewallClientConfigZone' object has no attribute 'settings'

Expected results:
No errors

Additional info:
The description seems to be saved in /etc/firewalld/zones/public.xml:

<?xml version="1.0" encoding="utf-8"?>
<zone>
  <short>Geoblock ipset</short>
  <description>Geoblock ipset</description>
  <service name="dhcpv6-client"/>
  <service name="ssh"/>
  <port protocol="tcp" port="2049"/>
  <port protocol="udp" port="2049"/>
</zone>

and the --get-description shows this:

# firewall-cmd --permanent --ipset=geoblock --get-description
Geoblock ipset

Comment 2 Thomas Woerner 2017-01-26 12:06:11 UTC
The options --{set,get}-{short,description} have not been used for ipset and helper in firewall-cmd and for helper in firewall-offline-cmd.

Comment 7 Thomas Woerner 2017-05-03 13:56:03 UTC
Settig back into ASSIGNED state to merge fix for #1445238, which is related.

Comment 9 Thomas Woerner 2017-05-03 13:58:04 UTC
*** Bug 1445238 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2017-08-01 16:22:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1934


Note You need to log in before you can comment on or make changes to this bug.