Bug 1416339 - The USER_DEACTIVATE_STORAGE_DOMAIN_OVF_UPDATE_INCOMPLETE audit log message is missing
Summary: The USER_DEACTIVATE_STORAGE_DOMAIN_OVF_UPDATE_INCOMPLETE audit log message is...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-4.0.7
: ---
Assignee: Liron Aravot
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On: 1410105
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 10:32 UTC by Tal Nisan
Modified: 2017-03-16 15:31 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1410105
Environment:
Last Closed: 2017-03-16 15:31:52 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0542 0 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0.7 2017-03-16 19:25:04 UTC
oVirt gerrit 68924 0 None None None 2017-01-25 10:32:08 UTC
oVirt gerrit 69606 0 None None None 2017-01-25 10:32:08 UTC
oVirt gerrit 69645 0 None None None 2017-01-25 10:32:08 UTC

Description Tal Nisan 2017-01-25 10:32:08 UTC
+++ This bug was initially created as a clone of Bug #1410105 +++

Description of problem:
The audit log message USER_DEACTIVATE_STORAGE_DOMAIN_OVF_UPDATE_INCOMPLETE translation is missing, causing to the audit log to not be added.

How reproducible:
Always


Steps to Reproduce:
1. Deactivate a non master data storage domain
2. Restart the engine during the ovf update (UploadStream) execution

Actual results:
No audit log appears

Expected results:
The USER_DEACTIVATE_STORAGE_DOMAIN_OVF_UPDATE_INCOMPLETE audit log message should appear (Failed to deactivate Storage Domain ${StorageDomainName} as the engine was restarted during the operation, please retry. (Data Center ${StoragePoolName}).

--- Additional comment from Sandro Bonazzola on 2017-01-25 09:54:38 IST ---

4.0.6 has been the last oVirt 4.0 release, please re-target this bug.

Comment 1 Kevin Alon Goldblatt 2017-02-19 18:41:25 UTC
Verified with developer on dev system

Tested with the following code:
------------------------------------------
ovirt-engine-4.0.7-0.1.el7ev.noarch
rhevm-4.0.7-0.1.el7ev.noarch
vdsm-4.19.4-1.el7ev.x86_64


Moving to VERIFIED!

Comment 3 errata-xmlrpc 2017-03-16 15:31:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0542.html


Note You need to log in before you can comment on or make changes to this bug.