Bug 1416345 - Reports fail when selecting a Custom Attribute containing one or more dots
Summary: Reports fail when selecting a Custom Attribute containing one or more dots
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.8.0
Assignee: Libor Pichler
QA Contact: Gilad Shefer
URL:
Whiteboard: container:chargeback
Depends On:
Blocks: 1416220 1433979
TreeView+ depends on / blocked
 
Reported: 2017-01-25 10:38 UTC by Federico Simoncelli
Modified: 2018-06-06 11:44 UTC (History)
8 users (show)

Fixed In Version: 5.8.0.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1433979 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:40:14 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)

Description Federico Simoncelli 2017-01-25 10:38:05 UTC
Description of problem:
It is impossible to define a new Report selecting a custom attribute as field when such attribute name contains one or more dots.

How reproducible:
100%

Steps to Reproduce:
1. Define a new Report selecting a custom attribute with dots as field, e.g. "kubernetes.io/hostname"

Actual results:
The Report fails

Expected results:
The Report should succeed and report the correct values for the selected custom attribute.

Additional info:
Reference to upstream issue: https://github.com/ManageIQ/manageiq/issues/10482

Comment 7 Libor Pichler 2017-03-20 12:17:10 UTC
Satoe,
> 
Regardless, what about other PRs you listed https://bugzilla.redhat.com/show_bug.cgi?id=1416345#c3  Are they not needed?

No. we choose different way to solve it.
-----
 
Ok I was looking to Target Release, so ok 

Upstream PR: https://github.com/ManageIQ/manageiq/pull/14329
Euwe PR:     https://github.com/ManageIQ/manageiq/pull/14363

Comment 9 Gilad Shefer 2017-03-30 14:21:08 UTC
Needs more information for reproduce.
(Base the report on?)

Comment 10 Ari Zellner 2017-04-02 11:06:48 UTC
This is a generic reporting issue so you can base the report on anything you have  data of to test this. Lets test on chargeback(projects or images) since this is where the issue originated.
Please test on columns with other special character too(slashes\commas\hyphens\spaces - anything that isnt a letter or a number) and see that the data is correct

Comment 11 Gilad Shefer 2017-04-24 09:06:32 UTC
I tried to create a report but I didn't see any option to add custom attribute as column (I have static custom attributes for the provider). which kind of custom attributes should I have and is it should be appear in the "Configure Report Columns::Available Fields" in the adding new report form?

Comment 12 Einat Pacifici 2017-05-10 10:38:56 UTC
Verified. Generated report with many "My Company Tag: xxx".
Report was generated and all fields were visible.


Note You need to log in before you can comment on or make changes to this bug.